Schema of internal link meta itemprop url showing http version


(Vikas Dangi) #1

my forum has installed ssl and all is working fine. But a single problem I am facing is that in the source code the schema internal links has http version of forum. Because of this google first index https version of the page and after 3-4 days it re-index the same page as http. I have checked this on many urls of my forum.

Here is the example of an url in source code

<div itemprop='itemListElement' itemscope itemtype='http://schema.org/ListItem'>
      <meta itemprop='url' content='http://defenceforum.org/t/isro-gears-up-to-flag-off-cryogenic-stage-on-march-27/300'>
      <a href='/t/isro-gears-up-to-flag-off-cryogenic-stage-on-march-27/300' itemprop='item'>
        <span itemprop='name'>ISRO gears up to flag off Cryogenic Stage on March 27</span>
      </a>
      <span class="page-links"></span>
        <span class='category'>[<a href='/c/indian-affairs/science-technology'>Science &amp; Technology</a>]</span>
      <span class='posts' title='posts'>(1)</span>
    </div>

(Jay Pfaffman) #2

Have you reloaded? I just checked and https://defenceforum.org/t/isro-gears-up-to-flag-off-cryogenic-stage-on-march-27/300 looks good to me:

and checking under the Security tab in Chrome’s developer thing, it says “All resources on this page are served securely.”


(Vikas Dangi) #3

Yes the ssl is working fine. But my problem is that google re-indexing my urls as http version because the schema of the internal links has http version.


(Jay Pfaffman) #4

Try searching your settings for “http:”. Perhaps you’re referring to the insecure site in some setting.


(Vikas Dangi) #6

Thanks, I forgot to enable force https in settings. My problem is solved, thanks for helping.