Secure Media Uploads breaks Group flair image

2.7.0.beta1 ( ae114a6ee8 )

I assume it has something to do with secure media because the upload of an image as group flair still works (it has the X-amz credentials) but after a refresh the display of said image gives a 403, access denied (the X-amz credentials are missing). Groups flair Icons work fine, and otherwise uploads, avatars, category logos, also fine.
It seems quite similar to this one Secure Media Uploads breaks Category Logos - #2 by martin , but I’m almost sure I has worked between the fix of Martin and now (worked with 2.6.0 beta5 if I’m not mistaken).

I still can’t make it work ( 2.7.0.beta3 ( 7fe5368718 ) ) :pleading_face:

I wonder if group_flair shouldn’t be a public type ?

1 Like

You are right, I am making a fix for this here, which will include a migration to fix incorrectly marked secure group flair uploads FIX: Do not mark group_flair images as secure on upload by martin-brennan · Pull Request #12081 · discourse/discourse · GitHub

3 Likes

and it’s working :smile: :+1:

2 Likes