Should I be running 1.8beta? or 1.7 release?


(John Lorance) #1

Just setup Discourse. It’s super awesome! I’m currently doing my build out to roll this out to my community; however, I’m wondering if I should be running on the Beta version that installed with the container/wizard based installer or should I be running 1.7 which is what is highlighted on the Discourse homepage?

Just curious about the distinction.


(Mitchell Krog) #2

Running the beta myself, also a new user, working 100%


(ljpp) #3

Many will disagree, including Dicourse devs, but I recommend 1.7 stable. You should have better things to do than upgrading your instance (= downtime) every other week.


(Jeff Atwood) #4

All our customers run beta. if you run stable you will miss out on a lot of bug fixes, performance improvements, and enhancements. Only “critical” bug fixes are backported to stable so there are a lot of little bugs that go unfixed for months on stable.


(Jay Pfaffman) #5

Upgrades are not that hard. The only reason they I can see to run stable is if you run any non supported plugins.