Sidekiq email errors and settings issue

I’ve just succeeded in installing Discourse (on an aarch64 Oracle Cloud server). After some difficulties, it works. I got the email confirming my registration as the admin for my site, and the site is set up now.

I have a couple of important early issues, though. First, I sent out a couple of invites, but they didn’t go out. They are stuck, visible as such in the Sidekiq admin area. My email host does require sender auth. I have read the Troubleshooting email on a new Discourse install FAQ. But I’m not sure why Discourse could successfully send me the confirmation of my registration, but the invitations to users are contrarily hanging.

A second issue is that, while Discourse’s interface is in my preferred language (US English), Sidekiq’s admin panel is in German. This is kind of a no-go. It’s not a terrible issue for me personally, because I’m fluent in German. (The server is in Germany.) But I expect others at my organization will be looking at the Sidekiq admin panel, and they don’t all speak German.

I tried to find where Sidekiq is on my server to see if there is a settings file I could edit, but so far, locating it has eluded me. (Too many hits with ‘find’ in temp-dir areas, etc.)


Postscript to say I did finally notice the link to Sidekiq info down in the bottom panel of the admin page. The text and links on the banner down there is hard to notice because it’s anthracite grey on a black border. :slightly_smiling_face: I presume I’ll be able to get to the settings at config/sidekiq.yml, then. I’ll go there shortly and look around.

My Discourse site is here. No discussants but me so far. :smile_cat:

How far have you strayed from a standard install? Are you using an external redis?

I tried to follow the standard installation instructions closely. No external redistribution; I didn’t know there were such. :slight_smile:

The mail issue seems to be solved now. The language issue with Sidekiq probably remains. But I am tired this morning and so far I can’t even find how I got to that screen yesterday. :sweat_smile:

My guess is that there is an environment setting that specifies German in the host os and that’s getting recognized by sidekiq somehow…

Maybe try something like

  set| grep -i de

And look for something that is setting the locale to German. Then you’d fix it in… Somewhere. I think there’s already a setting in the app.yml, though.

Good idea, but there’s nothing there:

root@discourse:/var/discourse# set | egrep -iw '(en|de)'
root@discourse:/var/discourse# env | egrep -iw '(en|de)'

The app.yml file is set with US English.

[In my screenshot, “Fehlgeschlagen” means “errors.” The number is high because I spent the last two days trying to resolve the mail issue. I finally succeeded a couple of hours ago. Yay! Part of that problem lay with my mail host, Dreamhost, however. The control panel there has some serious issues.]

1 Like

I might as well post a big part of how I solved my problem with email sent through Dreamhost. I added a line to the email area of app.yml:


1 Like

But are you running all this within a Docker environment? The server location should not matter.

1 Like

Yes. I had never heard of Sidekiq before yesterday. And I had never heard of Discourse before last Friday! :slight_smile: When I heard about Discourse, I knew I wanted to try to get it going on a server. And I went and got the server! As best I could, I followed the recommended instructions. I had a lot of heartbleed along the way until today, but now it’s all running well, I think, except for German language in Sidekiq.

Let me add that the first build I did had Discourse default to German. I went and found the language settings and changed it. But the build was not yet fully functional anyway, and I rebuilt it a few times after that before I got it working right. All new builds have always been in English.

Ah, so perhaps redis gets its language set on just the first run. You might delete the redis directory and rebuild, you shouldn’t lose much if it’s a new community. Redis isn’t backed up when you do a backup (to give you an idea that it won’t matter much)

1 Like

Very good, that did solve the language issue with sidekiq. Thank you!

On the down side, my theme is gone. I’m back to the default dark theme. All the optional themes that I ran through and selected from at the initial install and configuration are absent. I see the option of pulling in other themes, but what’s the easiest way of finding the original selection that was offered when I first built the package?

I have to walk most of that back. Color me confused, but Sidekiq was pulling the language from my Google Chrome browser’s settings! It was set to display browser menus in German. (I’m not sure how it got that way.) And now my theme colors are back in Chrome. Perhaps I had set Firefox for a dark theme, I will have to check. In any case, the issue was not actually from redis, it seems! A slap-one’s-forehead moment.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.