Since 3.2.1 I get 500 Errors on every action

With 3.2.3 I get this (when I try to post a topic, edit one, approve posts, etc.)

2024-07-06T00:39:23.066901838Z NoMethodError (undefined method `trusted_users_can_edit_others?’ for SiteSetting:Class)

I also get this:

24-07-06T00:39:24.067196373Z ActionView::Template::Error (undefined method `escape_uri' for UrlHelper:Class)
2024-07-06T00:39:24.067198898Z lib/plugin/instance.rb:541:in `block in on'
2024-07-06T00:39:24.067201202Z lib/discourse_event.rb:12:in `block in trigger'
2024-07-06T00:39:24.067203586Z lib/discourse_event.rb:12:in `trigger'
2024-07-06T00:39:24.067205881Z lib/pretty_text.rb:484:in `excerpt'
2024-07-06T00:39:24.067208165Z app/models/post.rb:523:in `excerpt'

I use the Bitnami 3.2.3 Discourse installation on CapRover.
I don’t have any plugins, but I have the RO locale enabled.

I tried all images (3.2.1, 3.2.2, 3.3.3), but still the same error. Everything else seems to work ok, and it worked fine before the 3.2 update.

Here’s the entire stack trace if needed:

2024-07-06T01:01:05.331159453Z Completed 500 Internal Server Error in 287ms (ActiveRecord: 0.0ms | Allocations: 46431)
2024-07-06T01:01:05.331163440Z NoMethodError (undefined method `escape_uri' for UrlHelper:Class)
2024-07-06T01:01:05.331167227Z lib/plugin/instance.rb:541:in `block in on'
2024-07-06T01:01:05.331170603Z lib/discourse_event.rb:12:in `block in trigger'
2024-07-06T01:01:05.331173679Z lib/discourse_event.rb:12:in `trigger'
2024-07-06T01:01:05.331176945Z lib/pretty_text.rb:484:in `excerpt'
2024-07-06T01:01:05.331180312Z app/models/post.rb:523:in `excerpt'
2024-07-06T01:01:05.331183558Z app/models/post.rb:532:in `excerpt_for_topic'
2024-07-06T01:01:05.331186833Z lib/post_creator.rb:506:in `update_topic_stats'
2024-07-06T01:01:05.331190089Z lib/post_creator.rb:196:in `block in create'
2024-07-06T01:01:05.331193455Z lib/post_creator.rb:390:in `block in transaction'
2024-07-06T01:01:05.331197323Z lib/post_creator.rb:390:in `transaction'
2024-07-06T01:01:05.331200789Z lib/post_creator.rb:188:in `create'
2024-07-06T01:01:05.331203995Z lib/new_post_manager.rb:318:in `perform_create_post'
2024-07-06T01:01:05.331207261Z lib/new_post_manager.rb:252:in `perform'
2024-07-06T01:01:05.331215837Z app/controllers/posts_controller.rb:201:in `create'
2024-07-06T01:01:05.331219554Z app/controllers/application_controller.rb:423:in `block in with_resolved_locale'
2024-07-06T01:01:05.331223071Z app/controllers/application_controller.rb:423:in `with_resolved_locale'
2024-07-06T01:01:05.331226587Z lib/middleware/omniauth_bypass_middleware.rb:64:in `call'
2024-07-06T01:01:05.331229904Z lib/content_security_policy/middleware.rb:12:in `call'
2024-07-06T01:01:05.331233230Z lib/middleware/anonymous_cache.rb:393:in `call'
2024-07-06T01:01:05.331236506Z lib/middleware/gtm_script_nonce_injector.rb:10:in `call'
2024-07-06T01:01:05.331239702Z config/initializers/008-rack-cors.rb:14:in `call'
2024-07-06T01:01:05.331242908Z config/initializers/100-quiet_logger.rb:20:in `call'
2024-07-06T01:01:05.331246204Z config/initializers/100-silence_logger.rb:29:in `call'
2024-07-06T01:01:05.331249290Z lib/middleware/enforce_hostname.rb:24:in `call'
2024-07-06T01:01:05.331252456Z lib/middleware/request_tracker.rb:236:in `call'

Then you can ask them for support. If you want help here you need to do a standard install.


I checked it initially, and the installation guide seemed very long (so I chose the available 1-click install available on CapRover).

Is there an easy way to replace the Bitnami installation with the standard one? (while keeping the current db/posts/users) ?

You should be able to make a backup and restore it to the new server. will do an automated standard install. You can join the free trial group and use for free, with very limited free support for the installation process

1 Like

Unfortunately the Standard Install doesn’t work for me, as it requires Docker to be available within the Discourse image. I already use Coolify now to manage my containers, so if I copy the git repo inside that container, I would have to install Docker within a Docker container for it to work.

I will try to make it work using, but that requires the Launcher, which means I can’t completely install Discourse in an isolated Docker container, without doing Docker-ception…

EDIT: I also tried to use this, discourse_docker/image/base/Dockerfile at master · discourse/discourse_docker · GitHub, but it doesn’t work either (plus the file seems old/unmaintained).

> [24/50] RUN /tmp/install-nginx:
53.52 objs/addon/static/ngx_http_brotli_static_module.o \
53.52 objs/ngx_modules.o \
53.52 -Wl,-Bsymbolic-functions -fPIE -pie -Wl,-z,relro -Wl,-z,now -ldl -lpthread -lpthread -lcrypt -L/tmp/ngx_brotli/deps/brotli/c/../out -lbrotlienc -lbrotlicommon -lm -lpcre -lssl -lcrypto -ldl -lpthread -lz \
53.52 -Wl,-E
53.55 /usr/bin/ld: cannot find -lbrotlienc
53.55 /usr/bin/ld: cannot find -lbrotlicommon
53.55 collect2: error: ld returned 1 exit status
53.55 make[1]: *** [objs/Makefile:324: objs/nginx] Error 1
53.55 make[1]: Leaving directory '/tmp/nginx-1.21.0'
53.55 make: *** [Makefile:13: install] Error 2
58 |
59 | ADD install-nginx /tmp/install-nginx
60 | >>> RUN /tmp/install-nginx
61 |
62 | RUN apt -y install advancecomp jhead jpegoptim libjpeg-turbo-progs optipng
ERROR: failed to solve: process "/bin/sh -c /tmp/install-nginx" did not complete successfully: exit code: 2
1 Like

Reverting to Docker image bitnami/discourse:3.0.6 fixes the 500 Errors, and I can create posts again. I will stay on this version for a while, and try again when a new one is released.

I hope that Discourse will soon provide a usable Docker image, that can be simply installed, without using other scripts or tools.

You can close this topic.