Site throws a blank screen after trying to enable LetsEncrypt


(Arun Sathiya) #1

I tried to follow the guide mentioned on this page but the site shows me a white screen on http:// version and throws a “unable to connect” error on https:// version. I am not sure what problem is. Can someone help me here? Thanks!


(Alan Tan) #2

Have you gone through the debugging steps?


(Arun Sathiya) #3

Well, I tried to see if certs were installed right. It showed total: 0. I tried Manually reissue the cert next and got it installed right. It shows total: 4 now.

But now, even the http:// version is messy now. Shows me “unable to connect” error. I do not understand the logs completely, but AFAIK, it shows that there is something messy with the cert installation.

Any leads here? Thanks!


(Alan Tan) #4

Can you try the following commands?

./launcher enter app
sv reload nginx

(Arun Sathiya) #6

Now it shows Error response from daemon: Container app is not running when I run this.


(Alan Tan) #7

What does docker ps show?


(Arun Sathiya) #8

It shows this?


(Alan Tan) #9

You need to start the container again before running those commands.


(Arun Sathiya) #10

I have no idea what just happened. But, I rebuilt the app and now, my Discourse setup is on HTTPS! The certs seems to be installed just right too. Thank you so much on the help, @tgxworld! :smiley: