SMTP Email Doesn't Work on Synology DSM 6

unsupported-install

#1

I installed Discourse on a Synology RackStation using the Discourse Docker package from the Synology Package Center. It shows the package is published by Civilized Discourse Construction Kit so I assume it’s an officially supported package.

Trouble is there is zero documentation with it and I’ve tried for 2 days to get email notifications to work without success. This means I’m stuck, unable to even activate my admin account to complete the setup.

I’ve read through many suggestions here on the forum but most of them involve editing .yml files and I can’t even find those files on my system.

I need some guidance on troubleshooting this issue, starting with the basics of how to access configuration on the Synology NAS.


(Jay Pfaffman) #2

If you don’t install using the install cloud instructions, it’s not officially supported.

You need to get the good people at synology to help you with the installer that they made.

Or

If you can ssh into the box, and it runs Docker, both of which seem fairly likely, you can follow the install instructions that I linked to when you asked the same question in another topic. And then, you should be able to run disourse-setup and follow the mail troubleshooting document and all of the other information that you have found here that by your own report doesn’t apply to your situation.


#3

I did contact Synology and their reply was “…we did not develop the package…” and just pointed me to this forum.

Unfortunately that topic (along with my entire account) was removed yesterday when my account was mistakenly flagged for spam. I spent a good bit of time yesterday with support just to regain the ability to post. Could you please link to those threads again?


(Jay Pfaffman) #4

Then you’ll need to play by the install guide here. Either their installer makes things easy and works, or it’s worse than nothing.

That’s horrible! I noticed something strange when I replied to your first message. That explains it.

My powers here are limited to changing titles and adding tags.

It’s hard to imagine that you’ll have performance to make this worth your time, but if I were to waste time on such a project that will likely not be useful even when you succeed (as I have more times than I care to admit! ), I’d follow this guide DiskStation Manager - Knowledge Base | Synology Inc. and then follow the standard install docs here.

My guess is that docker is already installed, and if that’s the case, it should work according to plan. If it’s not, you should probably give up.


(Andrew Waugh) #5

I tried discourse on docker about a year ago.

The docker wasn’t really docker, the discourse was a really old container which wouldn’t update, and synology isn’t a full Linux install.

@Tyson_Clugy: if it were me, I would spend a few hours seeing if the syno/docker/discourse package can be made to work, and if not then I would create a VM on the Syno, install Ubuntu, then follow the standard Discourse install.


(Jeff Atwood) #6

I guess it’s the Bitnami package, which we don’t support here. We only support our official install instructions which use Docker.


#7

So it turns out the package was outdated and I decided to just start over from scratch.
I set up a VM running Ubuntu Server and installed Discourse using the official method and everything is up and running smoothly.

Thank you for the recommendations.


(Régis Hanol) #8