[SOLVED] Can't Connect to the Server


(Bálint Antal) #1

I have just installed Discourse on Debian Wheezy and I’m not even able to connect to it by it’s IP address (+the port I set up). Safari says:

Safari Can’t Connect to the Server
Safari can’t open the page “xxx.xxx.xxx.xxx:8020”, because
Safari can’t connect to the server “xxx.xxx.xxx.xxx”.

My containers/app.yml file contains the following relevant options and it’s based on sample/standalone.yml:

expose:
  - "8020:8020"
  - "2222:22"

DISCOURSE_HOSTNAME: 'hereismydomain.com'
  • I ran ./launcher start app as root, because other users don’t have permission to use Docker.
  • I changed the port to :8020, because I am using Nginx on the server and I will want to make a proxy for my installation
  • as of that, I don’t want people to be able to connect directly on the port (I’m about to block it with iptables, but if you know a better solution, I’m open)
  • I have a server at DigitalOcean with 2 GB of RAM and I made a swapfile with 1 GB as everybody’s saying Discourse will thank it

Thanks!


(James Milligan) #2

Try changing the exposed port from 8020:8020 to 8020:80


(Bálint Antal) #3

Thanks that worked! :smile:


(Régis Hanol) #4