Some trouble updating (many bugs)

Hello,

I’m trying to update my discourse forum through the DigitalOcean droplet console. I’m not comfortable with docker

I tried this :

But got this error message :

too many arguments

After that I went to the link at the end of the error message :

And I tried to run this :

docker run -it --rm hello-world

I tried the cleanup, but I was afraid to loose something on my work.

Could anybody help me ?

Thank you for reading me.

Hi,
Considering your forum is up (you still can download a backup just in case) and assuming your host is not too far from up to date and this has previously worked, it might just be some transitory network trouble, could you try to rebuild again?

1 Like

You can run ./launcher start app to start your instance again without the update.

Regarding the error during the update, looks like an error on the hub.docker.com service. Try again later, they may be under some technical issues.

1 Like

It worked !

Looks like when i copy/paste the command :

cd /var/discourse
git pull
./launcher rebuild app

There was too many spaces and that’s why I got the “too many arguments” error :

So I just copy/paste line by line separately and it worked perfectly, thanks everyone for your time !