Some users getting "Unknown error" upon login

Hi everyone - strange issue. First, we are running the latest version of Discourse (as of this writing, it’s v2.0.0.beta6 +90). We’re on Nginx, though I don’t personally have access to the server itself.

Some of my users are telling me that whenever they attempt to login, they are getting an “Unknown error” returned to them. The “fix” is to disable their account in the Admin console and resend the activation email. Once they click on the activation link, their account works again. But, this keeps happening. In fact, it’s happening twice with a couple of my users.

I put in a trouble ticket with my hosting provider but they didn’t find anything obvious.

Has anyone seen this problem before?

No one has had this problem before, huh? Hmm…

How did you install Discourse? Did you follow our recommended setup?

1 Like

Run into this problem today. Weird, I saw several topics about it and one very good one as it had someone encountering it after restoring from backup… but I cannot find that one so I’m just posting here.

Moved one forum to another site today.

Everything was working just fine.

Then I tried enabling sso which hit one of the “stupid organization with too strict security policy”-snafus. Which really is weird as the other forum I’m using has sso enabled and works just fine. Did I mention stupid and strict security already? :smiley:

Anyway, went back to the normal login instead.

And suddenly the same username which worked well when logged in to the forum from outside now failed with “unknown error” when logging in from within the organization. Made absolutely no sense.

I checked I didn’t have https enabled in the original app.yml

After reading everything I could find on this forum I caved in and just tried enabling https.

And suddenly logging in worked.

(tried a clean browser without cookies etc just in case, that didn’t help)

No idea why but apparently enabling https is worth trying as a solution, thankfully Discourse makes Let’s Encrypt usage a breeze.

Verified on [v2.3.0.beta4 +39]

1 Like