Sometimes PDF-files cannot be openend


We are using Discourse as a knowledge base with a lot of documents. Since yesterday, not all PDF-files can be opened anymore. When clicking the link to download the PDF-file, a new page opens with the notification ‘Oops! That page does not exist or is private.’.

This is not for all PDF-files we have on the forum. We already looked at file size, file name, different applications to change/save PDF-files, as well as creating new posts, but unfortunately we could not find the problem. Strange thing is everything worked last week, there was no update of anything at all (including plugins etc.).

Anyone knows how to solve it?


We have a community with +1.000 members, they are very unhappy at the moment!

Are you self-hosting? Did you follow our official install guide? Anything unusual about your setup?

1 Like

Hi Jeff,

We are self-hosting and used the official installation guide. Thing is, we did that two years ago and had no problems up to a month ago without updating or anything else.

Sorry. You don’t offer any clues as to why they might be the case. No one else has reported having the same issue. If you really did nothing and the issue started without your even doing an update it’s even harder to propose a course of action.

Are the files that you’re getting errors for in the file system? Are they somehow in tombstone? You might try the recover from tombstone rake task and see if it helps.

I make my living helping self hosters. I could take a look for a fee, but can’t make any promises as I have absolutely no idea what might have caused the problem or if it’s possible to fix it.

1 Like

I know I can’t provide any clues, we’ve been looking for them for a couple of weeks now but there seems nothing to have happened what might have caused it.

The files are in the file system. The strange thing is that when we upload the files again in a new post, they can be opened and downloaden, but not in the original post. Due to the structure of our website, it is not possible to create all new kinds of posts. We are a closed community with management board members globally who use the website on a daily base, so unfortunately I cannot give you access.

Thank for thinking with me, I think we might have to think of another solution. Thanks!

Have you tried rebaking a post with a problematic PDF?

:wrench:Rebuild HTML

If that works, you can rebake all posts with PDFs.


Closed per request of the OP author.