SSO client link giving error 500

I have done the following to setup my word press as a SSO client:

On wordpress

  1. added all fields in the “connection” tab

  2. added by secret key

On discourse

  1. enable SSO provider

  2. add SSO secret key

Although, when i try and sign in I get the following screen.

Capture

How could I fix this?

My guess is that the problem is because of what you are asking about here:

Could you try using the default WordPress .htaccess configuration and see if you are still getting an error?

Instead I just reverted back to a wordpress backup from 2 days ago (with the original htaccess file). Although, the problem was still there. But when I cleared all my cache. cookies and history, it started to work again.

Kind of a weird situation but im glad I sorted it out.

1 Like

Do you think the wp optimize plugin could have anything to do with this?

I don’t know. If you can figure that out, and why that is the case, please let us know. We can’t get into a lot of WordPress development on this forum, but it’s good to know about conflicts between the WP Discourse plugin and any other WordPress plugins. It makes debugging issues a lot easier.

1 Like

For anyone else experiencing this error, I fixed it by filling in the sso provider secrets setting for the client domain name:

In the Discourse code, when this secret is not set, the call to OpenSSL::HMAC.hexdigest fails with the following error in the logs:

TypeError (no implicit conversion of nil into String) /var/www/discourse/lib/single_sign_on.rb:114:in `hexdigest’

Here is the relevant code path:

This error message should definitely be improved! Edit: and it has been - see Confusing/unpolished error message when using Discourse as SSO provider