Strange Permissions issue - help needed

I’m relatively new to Discourse having moved my 500K+ post community to the software late in 2017.

I am the Owner and Administrator of my site. I have a Member only Category that has 2 sub-categories. I have setup the Category and sub-categories to only allow Members to see, read, and post in those categories.

My issue is that I can’t see posts in any of those categories when I view the Latest posts. I can view, edit, and post in the Categories when navigate using Categories.

If I login as my Test account (TL 1) I can see posts from these Categories under “Latest”.

Here are the permissions for the Category:


The sub-categories are configured the same.

At the top of the Category List when logged in as myself, I see:

I do not see this when I login as my TL1 Test account.

My user permissions are:

I would really appreciate some assistance with this as I’ve tried everything to no avail.

Why do you include all the trust levels with create/reply/see? There is a special group “everyone” that includes… everyone, which should be sufficient :slight_smile:

1 Like

I don’t want to include non-members. As I understand it, ‘everyone’ also includes guests.

1 Like

Have you accidentally muted the category? Head to /my/preferences/categories and check the list of muted categories there.


You are completely right :slight_smile:

afaik, it is enough to include trust_level_0, since the other TLs are a subset of this.


No :frowning:

I just tested this and could not see posts on the Latest List as a guest. :slight_smile:

I could see the posts on the Latest List as my TL1 Test account :slight_smile:

I could not see the posts on the Latest List as myself (TL4, Administrator) :frowning:

1 Like

“have you tried turning it off and on again”, as in, maybe it helps to log out, log in and try again?

Could you try to create a test post with the TL1-test account and see if you see that one?

1 Like

Good thinking!

I logged out and then back in again. No change

I created a test post in the Member only category, but am unable to see it listed under “Latest” when logged in as my Admin account.

Do you have the shared drafts category site setting enabled?


Stranger still, I can see a post on the Latest list which was posted in a sub-category of the Member Chit-Chat Category. Just can’t see posts in the Member Chit-Chat category.


I selected another Category and now I can view the Member Chit-Chat category.

Thank you so much @david!

Thanks also to @Bas for helping out.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.