Suddenly all CDN links are https rather than http, what happened?


#1

Hi,

I have no idea when this happened but I guess it was after some upgrade, all uploaded images were no longer http but https. I’ve talked to my CDN ISP but they said it was discourse that made the change.

Is that so? How can I keep using http?

Thanks.

Yinglu


(Matt Palmer) #2

Did you tick the “use https” site setting?


#3

You mean this?


(Matt Palmer) #4

Yes, that’s the setting I was referring to.


#5

I haven’t turned on this option. Any other ideas?


(Matt Palmer) #6

What site are you referring to, so that we can see the actual behaviour you’re talking about?


#8

You can post an image on 关于最近论坛图片不能显示的说明 - General Chitchat | 聊天吹水 - iOSRE with username snaken1nny and password newpassw0rd, thank you!


(Fer Nando) #9

I have the same problem in my forum, i use http only and when apply cdn, all site images are forced to https.


(Michael - DiscourseHosting.com) #10

And this is a problem why?


(Fer Nando) #11

If you dont have a ssl certificate, some browsers refund to display the images, this is my case.


#12

As @Fer_Nando said, both Chrome and Safari refuse to display the images without a valid certificate


(Michael - DiscourseHosting.com) #13

The CDN ISP provides a certicificate for you, right?
Which CDN are you using?


#15

Yes, I can request for a free certificate but I didn’t. The CDN is from QiNiu, based in China.


(Fer Nando) #16

I maked free cert in cloundfront, this solve my problem but other admins of discourse dont have an option for disable https in images when enable the cdn option, this is a small bug.


#17

Is this a confirmed bug? @mpalmer


(Sam Saffron) #18

I don’t know and I doubt Matt can help you here :slight_smile:

Can you confirm:

  1. you are running latest?

  2. your DISCOURSE_CDN_URL is set to: http://7xibfi.com1.z0.glb.clouddn.com ? (note how it is http there and not https)


(Fer Nando) #19

The question is for me?

I have “DISCOURSE_CDN_URL: //cdn.domaincname.com” in cdn option, no http or https set here.


(Sam Saffron) #20

Then change it to:

DISCOURSE_CDN_URL: "http://cdn.domaincname.com"

Otherwise we will pick HTTPS for you.


When I enabled CDN all my Emoji broke