Summary does not display oneboxed images

pr-welcome

(Miguel) #1

Hi!

Since the last update I have seen something that does not work well. Any content inside a Summary is not displayed (image, youtube video, gif, mp4, etc.), only the link is displayed. Before this did not happen, the Summary content was displayed correctly.

Any ideas?

Thanks!

Edit:

Okay, I see that the same thing happens here too :open_mouth:

Summary

http://i.imgur.com/CCNdQ8e.jpg


(Joshua Rosenfeld) #2

I can repro.

Summary

https://i.imgur.com/CCNdQ8e.jpg


(Miguel) #3

I do not understand. Sorry, my english is very bad! :smile:


(Joshua Rosenfeld) #4

My apologies. Repro is short for reproduce. I was confirming that I can follow the steps you provided and make the issue you’ve reported occur myself.


#5

Not sure if this is related, but I just stumbled upon a similar issue:

I have an empty quote

… or do I?

[details="I have an empty quote"]

> ![image|690x75](upload://NhDzLiw1SK7W5nA5MpCrFPqL75.jpg)

[/details]

Weirdly, this works fine on the preview panel inside composer.


(Miguel) #6

I have updated to the latest version and the bug is still present :frowning:


(Eric Berry) #7

This is a test to see if it’s still an issue:

Summary

69c354c204760a4319171bc6245bcfdc


(Eric Berry) #8

It appears this has since been fixed for new summaries? It’s odd that it hasn’t retroactively fixed the other examples above on this thread.

I’ll dig in a little bit and see what I can find.


(Jeff Atwood) #9

Why is that odd? Posts are baked into HTML once, at post time, to save server time. They reflect the state of the code as of post time. If you want to rebake a post (and have mod / admin access), select the wrench menu and then rebake.

There’s also a global rebake rake task for all posts.


(Eric Berry) #10

Ah. I wasn’t aware. Sounds like this is a closed issue then :+1:t2:


(Jeff Atwood) #11

(Joshua Rosenfeld) #12

(Joshua Rosenfeld) #13

Hmm…I don’t think the bug originally reported is fixed. The report was for a oneboxed image failing in a details block.

This is an imgur link:

https://i.imgur.com/CCNdQ8e.jpg

This is the link oneboxed:

This is the link in a details block:

[details="Summary"]

https://i.imgur.com/CCNdQ8e.jpg

[/details]

This is the details block:

Summary

https://i.imgur.com/CCNdQ8e.jpg

Oneboxing is still not happening inside details.


(cpradio) #14

As a work around, they can use (note the empty lines above and below the image line)

<details><summary>Test</summary>

https://i.imgur.com/CCNdQ8e.jpg

</details>

Which produces

Test

(Joshua Rosenfeld) #15

Edited my post, still not working. Strange that the HTML details works but the bbcode details doesn’t.


(Eric Berry) #16

I’ll take a stab at fixing this.

@jomaxro I just want to confirm: Expected behavior is we do not need to use markdown to display images inline, correct?

For example, this should show the image inline:

[details="Summary"]

https://i.imgur.com/CCNdQ8e.jpg

[/details]

As well as this:

[details="I have an empty quote"]

![image](https://i.imgur.com/CCNdQ8e.jpg)

[/details]

(Joshua Rosenfeld) #17

@coderberry, that’s my understanding, yes. If that imgur link “expands” outside of a details block, it should expand the same inside.