Switched to HTTPS, 1 of the rss link is http


(Carlo Kok) #1

on https://talk.remobjects.com/

        <link rel="alternate" type="application/rss+xml" title="Latest posts" href="https://talk.remobjects.com/posts.rss" />
    <link rel="alternate" type="application/rss+xml" title="Latest topics" href="http://talk.remobjects.com/latest.rss" />

The first is fine (i changed the use https setting) the second isn’t, also the fontawesome links seem to still use http:

<style>
  @font-face {
    font-family: 'FontAwesome';
    src: url('/assets/fontawesome-webfont-e2f6015310d7f63fa1537ab9822f1446.eot?http://talk.remobjects.com&amp;2&v=4.5.0');
    src: url('/assets/fontawesome-webfont-e2f6015310d7f63fa1537ab9822f1446.eot?http://talk.remobjects.com&amp;2&v=4.5.0#iefix') format('embedded-opentype'),
         url('/assets/fontawesome-webfont-6d0ddb44b6016bd7adf993e5b9d47ae6.woff2?http://talk.remobjects.com&amp;2&v=4.5.0') format('woff2'),
         url('/assets/fontawesome-webfont-90e687312466f7a4993c85399c116f2f.woff?http://talk.remobjects.com&amp;2&v=4.5.0') format('woff'),
         url('/assets/fontawesome-webfont-f436f853ea7573a6b623eea9bc9d66ec.ttf?http://talk.remobjects.com&amp;2&v=4.5.0') format('truetype');
    font-weight: normal;
    font-style: normal;
  }
</style>

Did rebuild it, didn’t change anymore.


How to make Discourse use https:// links for itself?
(Carlo Kok) #2

I don’t see this on meta, which is weird.


(Neil Lalonde) #3

Is the use https setting enabled? Look in /admin/site_settings/category/security.


(Carlo Kok) #4

Yep.


(Sam Saffron) #5

Maybe something strange is cached, try dumping redis and rebuilding


(Carlo Kok) #6

How do I do that (the redis part)?


(Régis Hanol) #7

The :bomb: option is to redis-cli flushall from inside the container. That’ll remove everything from redis (you may lose some pending emails).


(Carlo Kok) #8

Did that. Then did ./launcher rebuild app; exact same result. What else could I be missing?


(Sam Saffron) #9

Where are you terminating SSL ?


(Carlo Kok) #10

Discourse itself is HTTP, (my own) nginx in front of it does https:

        location @fallback {
                proxy_pass http://unix:/sites/websites/discourse/discourse2/shared/standalone/nginx.http.sock:;
                proxy_set_header Host $http_host;
                proxy_http_version 1.1;
                proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        }



(Sam Saffron) #11

Try this