Тест на валидный сертификат для включения force_https сломан: он остаётся выключенным, хотя должен быть включён

Да, это действительно ошибка.

На прошлой неделе мы переносили форум на другой сервер и столкнулись с лимитом повторной выдачи сертификатов Let’s Encrypt (максимум 5 в неделю для одного и того же имени хоста). Сначала мы не понимали причины, но эта ошибка приводила к повторной выдаче сертификата при каждой сборке, и после пяти попыток мы уперлись в лимит. Это не вызвало тревоги, поскольку предыдущий сертификат всё ещё оставался на сервере.

Всё изменилось, когда мы перенесли форум на новый сервер. Там мы не получили новый сертификат. Мы могли бы скопировать его со старого сервера, но так и не поняли, что стало причиной проблемы.

acme.sh зафиксирован на версии 2.9.0, в то время как в ветке master сейчас версия 3.0.1, где есть функция установки цепочки по умолчанию. Я подозреваю, что это может быть связано с проблемой.

3 лайка