The "Hide Details" feature doesn't show up correctly in the preview window

The “Hide Details” feature doesn’t show up correctly in the preview window.

Here’s what it looks like in the preview:


I’d like to post what it actually looks like when the post goes live, but I’m limited to one embedded media item since I’m a new user. Suffice to say, it doesn’t say “Details” after the caret, but instead says “This text should be after the caret”. That should show up in the preview as well though, right?

Here’s what it looks like after creating the reply (having to post this as a reply to my own topic because I wasn’t allowed to post two images in the topic):


Does that also happen here at meta? Did you try safe mode with just official plugins?
For me everything seems normal

Never knew about “Safe Mode”, that’s cool! When I enable it, I don’t see the “Hide Details” feature at all and it doesn’t seem to work using the markup you provided:

It does work fine here on meta, though.

The details feature counts as a plugin, so you’d need to have your safe mode ticks like this:

1 Like

Still seems to be not working with those settings:


1 Like

That’s interesting. Though safe mode only disables the JavaScript bit of the plugins, so it may still be one of the ones you have installed having a deeper effect. I’ve tried using Details on my test site (c81d4597a7) and here on Meta, and it works as expected, so I think it may be a conflict in your setup rather than a bug in core. What other plugins do you have on that site?

Here’s what we have installed currently:

My guess is the top one. :slight_smile: I have Reactions and Solved on my test site (and docker_manager) and Details works fine, so it’s probably the unofficial one. Though, as the conflict persisted in safe mode, it’s likely that you would need to remove that plugin from your app.yml to test the theory.

Sounds good. That’s a plugin our students created to help out with common moderation issues and it’s much more important than the details preview working at the moment. When it’s after our peak business hours I’ll see if we can pull it out and test it to confirm your hunch. I suspect it’s correct. Thanks for the help! I’ll let you know how it turns out.

1 Like

No worries. :slight_smile: I’ll slide this over to the #support category, but we can always move it back later if it turns out it is a bug in core. :+1:

1 Like