The term "ost.io" creates trouble for search


(Erlend Sogge Heggen) #1

Search “ost.io” and you won’t find this thread:

Which has ost.io in both the title and the post body.


(Héctor Fernández) #2

It seems it can’t find anything ended in io, eg: astronomers.io, popcorntime.io. Also others like moter8.pw. And sometimes even part of the url: zenhub or bughubapp.


(Erlend Sogge Heggen) #3

Well the odd thing is that when I search for “ost.io” it’ll turn up results for this topic and another one where the term is used, but not that older topic where it was first mentioned.


(Héctor Fernández) #4

If it’s not a link it works. Notice that all the terms I entered can be found in this topic. In the other use of Ost.io that it finds (the one with the capital O) the link does not include the dot (https://changelog.com/ ostio-add-a-forum-to-your-github-project/


(Sam Saffron) #6

I really think snowball and the default english tokanization pg uses creates lots of issues.


(Erlend Sogge Heggen) #7

Is there a place we could forward this issue to then?


(Jeff Atwood) #8

One thing we are direly missing is quoted exact term search e.g. “Manifold carburetor” should match only that string in that order.


(Stephanie) #9

In case that functionality isn’t included in what you said: I’d also like to have that for individual words. I tried to search for “top” and got soooo many hits for “topic,” and while it’s often quite helpful to get results for permutations of the word, in this case it rendered the search pretty much useless.


(Erlend Sogge Heggen) #10

Dropping by to add another use case that’s hurt by this:

Having forgotten this bug, I just dropped by talk.jekyllrb.com and searched “3.0 eta”, looking for a topic I knew already existed. This search garnered no results of course, while “eta” got me exactly what I wanted.

The fact that you actually lose search results by including an invalid search term can be pretty detrimental on technical forums where searching for specific versions is not uncommon.


(Sam Saffron) #11

A bug indeed,

I just fixed it:

https://github.com/discourse/discourse/commit/139314c2133fb74a9e94ffbdc92f3551de279bea

Also added some rudimentary support for exact term matching.

Will take a bit till it is live here, cause rubygems is having a minor freakout at the moment.


(Sam Saffron) #12

(Sam Saffron) #13

done and working…

https://meta.discourse.org/search?q="quoted%20exact%20term"

vs

https://meta.discourse.org/search?q=quoted%20exact%20term


Searching with quoted term doesn't highlight the whole term