Theme changes only apply to admin

Hi, I am new to Discourse. I am running Discourse 3.2.0.beta4-dev. If I make a theme change, only Admin can see the theme change.

In admin/customize/themes I have Clean enabled.

In /u/admin/preferences/interface I have the following:

Color Scheme
Regular Theme Default (greyed out text)
Dark mode Same as regular

As the Admin user I see the Clean theme and it looks great (it has a white background).

Other users, not logged in using Brave, Safari, Firefox see the Default Dark Theme (with a dark background).

So my question is, what do I need to do so everybody will see the Clean theme with the white background?

Is your clean theme selectable by users?

Screen Shot 2022-06-15 at 10.07.10 AM

1 Like


This is what my admin/customize/themes looks like.

You will note the default theme is missing as I deleted it from the admin area. I had the same problem with the default theme in that if I changed it to white, only admin would see the change.

Laptop 1:
Brave: Admin logged in (white background)
Firefox: unregistered (black background)
Safari: unregistered (black background)

Laptop 2:
Brave: unregistered (white background)
Firefox: unregistered (white background)
Safari: unregistered (white background)

Safari: unregistered (white background)
Brave: unregistered

  • white header bar where logo login search hamburger
  • rest of the page has a grey background

Firefox: unregistered (white background)

Even if I close all browsers on Laptop 1 and restart the machine, Firefox and Safari will load the site with a black background. So I presume there is a setting stored in the browser cache somewhere. But then I tested by clearing the Firefox history, clearing every history and data setting. When I loaded the site afterward it still loaded with a black background!

If you want people to be able to select it, you’ll need to check that middle check box in the settings on the right.

Also, might I ask why you’re forcing all your users to have a very bright theme?

1 Like

I have found out the reason why Laptop 1 was showing a black background using Firefox and Safari. On MacOS I had Settings/Appearance/Dark selected.

This was also the reason why Brave on the iPad was not displaying the white background, as that was also using a Dark Mode.

Similar to this but we have uploaded our logos and they appear in top left corner of the page when in admin view but not when in non-admin view? can anyone please help with this

Do you have force-https on for your site?

I dont believe so. Refreshing it - it actually seems to work sometimes but other times it doesn’t so don’t know whether its just a glitch

Could you try enabling it then? That should resolve the issue.