Too many redirects after enabling https


#1

I’m trying to enable https on an existing forum using this guide: Setting up Let’s Encrypt

I ran ./discourse-setup and entered my email address for Let’s Encrypt, and then rebuilt the app.

However, now when I visit my server I’m getting this errors:

forum.happycoding.io redirected you too many times.
ERR_TOO_MANY_REDIRECTS

I’ve manually inspected app.yml and it appears that all of my settings are correct. I’m not using cloudflare or anything.

Is there a step I’m missing? Is there something special I need to consider when running my discourse on a subdomain?

As always, thanks for your time, and I appreciate any help anybody can offer!


(Jay Pfaffman) #2

I’m not sure what the problem could be. Could you try the unannounced discourse doctor and see if it sheds light?

git pull
./discourse-doctor

#3

As always it turns out that I’m an idiot. I had some upper-case letters in my domain (forum.HappyCoding.io). Modifying the app.yml file to only user lower-case letters (forum.happycoding.io) solved the problem.

I noticed this when I looked at the output for disocurse-doctor, so thanks very much!

Btw, I found a similar thread with a similar problem here.


(Jay Pfaffman) #4

Great! That’s what it’s supposed to do!

Was it just printing the configuration information or was it something else?


#5

Yeah, the discourse-doctor tool printed out the config data, which is where I saw the upper-case letters. That coupled with seeing this post and remembering encountering another problem with upper-case letters finally clicked everything into place in my brain.


(Jeff Atwood) #6

Maybe you can extend doctor to warn, or we can add a stop warning in setup, when people put uppercase characters in the domain name?


(Jay Pfaffman) #7

Or launcher could downcase the domain main name.


(Jeff Atwood) #8

Sure, whatever works and is easy!