Topics do not appear in the specified Slack channel


(Scott Kurinskas) #1

Hi -

I’m trying to enable Slack integration. We’re able to successfully push messages from Discourse to Slack when testing the integration, but when new topics are created, they do not appear in the specified channel. The rule supports all posts and all categories.

What specific fields must be specified for Slack integration? OAuth, Incoming Webhook, Outgoiong Webhook?

Thanks,
Scott


(David Taylor) #2

To make slack work you need to specify EITHER the oauth token, or the outgoing webhook URL. If you put both, the webhook will be ignored.

If the “test” button works, then there must be something going wrong with your rules. Are the posts in a private category? Are you seeing anything in the logs (visit /logs on your forum and see if there’s anything from chat-integration).

Can you post a screenshot of your rules page?


(JGray) #4

Was this solved? I am having the same issue. Commands work and content from our discourse appears in Slackbot, but I get (error message: 422_client_error) when I try to use the command in a channel.

I figured out. I was testing in private channels…doesn’t work with how I configured the rules.


(JGray) #5

I converted some public channels to private and the Discourse plugin to Slack is still posting messages, but I can’t seem to perform any slash commands. Getting:

“Darn - that slash command didn’t work (error message: 422_client_error).”

Is anyone having luck getting slack integration to work in private channels?


(JGray) #6

Hi @David_Taylor - Still getting the following message when I try to add posts to a private slack channel:
“Darn - that slash command didn’t work (error message: 422_client_error ).”

Discourse bot is added to the private Slack channel and I have played with a ton of settings, but can’t see to get it to work.

Posts are from private categories, which I can add to public channels in Slack with slack command. It is just an issue with private Slack channels. Oddly, if I add by slash command with the channel is public and then convert to a private channel, it works.

Thanks!


(David Taylor) #7

For now, a workaround is that you can use the discourse admin interface to configure rules, rather than slash commands. Go to admin —> plug-ins —> chat integrations —> slack


Getting 422_client_error when using slash commands in private channels
(JGray) #8

Thanks for the quick response. The only settings I am seeing there for Slack are the following. There doesn’t look to be a place to configure rules.

chat integration slack enabled - enabled
chat integration slack access token - filled in
chat integration slack incoming webhook token - filled in
chat integration slack excerpt length - 400
chat integration slack outbound webhook url - left blank
chat integration slack icon url - blank


(David Taylor) #9

Rule configuration is not under “site settings”, it has its own area. Click the “plugins” tab at the top of the screen, and then “chat integrations” on the left.


Getting 422_client_error when using slash commands in private channels
(RK) #10

So if I configured rules for a channel, I should be able to run slash commands on that channel, right? Does this apply to private channels as well? Because I can’t seem to get it to work on private channels for some reason.