Turning off RateLimiter::LimitExceeded entirely for one user?


(Jorge Castro) #1

We’re having issues running into this as we ingest some RSS feeds, I believe it’s because we’re using zapier to grab some feeds, which then has a 5 minute timer to send them to discourse, which it does all at once, triggering this. Is there a way to turn this off for one user? Clearly we don’t want it globally off.

Also I figured I would state my use case in case someone has a another way to do this. We’re trying to automate consolidating a bunch of different platforms into certain discourse categories. That way we can suck in certain videos from a certain channel, certain posts from certain blogs, certain releases from certain github repos etc. Right now Zapier seems to fit that nicely, we can just make a zap that takes what we need and then sends it to the right email category on discourse. Ideally a native Discourse plugin would handle this nicer than piping it through email, and people are asking for it, but alas, does not exist.

Currently I’ve got a dedicated closed category with email ingestion turned on, which then takes emails from zapier and turns them moderators hand curate the submissions and schedule them to be posted (or closes them.) This allows us to basically hand-curate a newsletter style category which is basically what we’re trying to do.


(Jay Pfaffman) #2

I believe that staff is immune to rate limiting.


(Jeff Atwood) #3

No, they’re not. Not the nginx rate limits because nginx doesn’t really know if a user is “logged in”, only the Discourse codebase knows that.

(nginx can look for the presence of a login cookie but it can’t validate that cookie)


(Sam Saffron) #4

Oh, this really depends on the rate limiter and we have an enormous army of rate limiters to pick from.

What particular rate limit on which particular route are you talking about?


(Jorge Castro) #5

The error is listed in the incoming “Rejected” email tab, clicking through on the error only shows me the email headers. Best guess is incoming smtp?


(Bob Killen) #6

Just to chime in with a bit more info (I’m an admin on the same board as @jorge_castro). We also tried setting rate limit create topic and rate limit create post to 0 (1 was tried as well) to see if the limit was imposed not from the email itself, but from creating topics and posts too quickly. Unfortunately we continue to see the RateLimiter::LimitExceeded error if more than one email is sent within a short period of time with no other information to be found in the logs.


(Sam Saffron) #7

Tracing through the various limits.

It is either max_replies_in_first_day or any of the 6 site settings with the words rate limit

Reading through our code I am not certain 0 as rate limit new user create post would take properly, besides it is not something you would want to run.

The API supports allowing admins to create posts and topics unlimited and then you can transfer ownership via the API. Maybe that is a better path to get this data in securely?


(Jorge Castro) #8

Making the ingest user we created an admin has worked! This is a suitable workaround until someone makes a zapier/discourse integration. Thanks for the advice everyone!


(system) #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.