TypeError: r is not iterable

Hi guys, I’m new to discourse.

I’m getting an error but I couldn’t find the reason. Could you help me with this?

I refresh the page and it gives the error I shared below in the chrome console. What should I do?

2 Likes

Hm, this is in “opcode-compiler”. What plugins do you have installed?

2 Likes

Can you test in safe mode as well? Does it work?

3 Likes

I have seen this same error locally, and I thought it was a regression but while I was trying to determine when this would have regressed (via git bisect) it magically got solved. I believe it was because there was a corrupt build cache that got reset while bisecting.

In a production environment, you can try rebuilding your site, there is a good chance that it will resolve the issue.

1 Like

Thanks for the safe-mode feature :slight_smile: I didn’t know that.
There was no problem in the default theme, after switching to the Discourse-Air theme, I found that the problem was there.

After removing the default plugins in the Discourse-Air theme, my problem was resolved. But which plugin etc. I haven’t been able to check.

2 Likes