Unable to activate account

Hey guys!
So im currently trying to setup discourse!

So far everything seems fine, email is all good etcet!

So when i first join my new discourse it tells me to register etc as normal, I input the admin password for the email to setup the account etc, I then get the email to activate the account and then well this is where my issues start!

I run the link emailed to me and then it brings me to the site and has a button Click here to activate account But nothing happens… Nothing at all the button is dead!

Why is this?



Are you using a domain name? That’s required.

How did you install?

I followed the installation guide on the GitHub page.

Yes i am using a domain, But even if i do it local to the maching i get the same issue.

I also tried to force activate the account which lead to a white screen when loading the website :confused:

1 Like

Could it because im using my domain name as is and not using a subdomain?

This behavior usually means your https is busted or you are going through some weird proxy like CloudFlare to generate fake https.

1 Like

At the moment im doing it via GoDaddy where my domain is from.

All i have done is forward the Domain to the IP the forum is run on?


So i did a fresh install of dscourse…

And when i use my domain the address bar shows the IP not the domain? Is that an issue with my DNS setup?

1 Like

did you run ./discourse-setup? When you did, did you give it a hostname?

I have the same problem with you :cry:

1 Like

You can see what ./discourse-doctor has to say. You can also share your domain name here so we could check your DNS settings.

1 Like

Thank you very much
my domain name is asiavaper.com

1 Like

There’s definitely something wrong with your https. Did you enable https by providing an email address to ./discourse-setup? Do you have some reverse proxy or other device forwarding traffic to the domain?

1 Like

Installed the same server a second time and encountered the same problem several times today.

If you look at your javascript console (F12 on many browsers), you’ll see

categories:25 Refused to load the script 'https://asiavaper.com/assets/locales/en_US-13bd90597606fb9c418137d59bfbf2505d12db86463283f82980508460bbb766.js' because it violates the following Content Security Policy directive: "script-src 'unsafe-eval' 'report-sample' https://asiavaper.com/logs/ https://asiavaper.com/sidekiq/ https://asiavaper.com/mini-profiler-resources/ https://discourse.sgp1.cdn.digitaloceanspaces.com/assets/ https://discourse.sgp1.cdn.digitaloceanspaces.com/brotli_asset/ https://asiavaper.com/extra-locales/ https://asiavaper.com/highlight-js/ https://asiavaper.com/javascripts/ https://asiavaper.com/plugins/ https://asiavaper.com/theme-javascripts/ https://asiavaper.com/svg-sprite/". Note that 'script-src-elem' was not explicitly set, so 'script-src' is used as a fallback.

I don’t know why stuff is linking to that Spaces CDN, but that’s likely the problem.

You just cloned discourse and ran ./discourse-setup?

I recommend that you remove those DISCOURSE_S3 environment variables until you get things working. It’s best to start without them and enter them through the web interface until you’ve figured it all out. Getting Spaces working is a bit of a trick.

1 Like

Ok, thanks for your help!

By the way, may I ask you another question?
I want to re-install the database into DigitalOcean Databases. How should I set it up? It’s been bothering me for days.

1 Like

My issues was down to me trying to send my domain to a none static IP (IE i was sending my domain to a home hosted PC) which ofcourse it didnt like, Switched to OVH VPS and works perfect :smiley:


Since it’s not a “standard install”, configuring DigitalOcean databases is beyond the scope of the support you’re likely to get here. If you need help with it and have a budget feel free to contact me directly.

It should be as simple as putting the credentials in as you can see in the web_only sample, but there are a number of things that can make it more complicated than that.

1 Like

I’ll try, but thank you very much for your help

:smile: :smile: :smile: