The activating account button doesn't work

I just installed Discourse on a Digital Ocean droplet and I received the activation email, but the blue button in the browser doesn’t do anything.
I reapplied a for a new activating code three times and all three times it’s the same.
The activation for the forum worked superbly, with the same email adress.
Is there anything I must alter here?

What mail client are you using? Can you right click on the link? Do you see a link as well as the button?

Thanks for the fast response, I use evolution as a mail client, but the problem is with the blue button in the browser. The mail link brings me to the right page and I only see the button.

How did you install discourse?

Do you have an ad blocker installed?

No, the same system worked for the activation for the forum, but not for Discourse.

How did you install discourse?

You have a different forum in addition to discourse?

No, I’m sorry for the misunderstanding. What I meant is that the same blue button worked when I registered for this forum.

How was the instance installed?

Have you tried opening the link in an incognito tab? What happens then?

I’ve installed it in the terminal, according to the “30 min manual” and I’ve tried to open it in a incognito tab, but the link in the browser (blue bar) stays unresponsive.

Let me guess you didn’t provide an email during the ./discourse-setup for Let’s Encrypt?

Can you try that step again, this time providing an email so the resulting site is HTTPS secured?

1 Like

Is there a known issue with not using HTTPS/Let’s Encrypt and activation?

Like I said it’s a guess, but this isn’t the first time we get the exact same complaint in Meta.

It’s that it? Thanks I’m going to try it immediately…I’l let you know.

Okay, now I lost the page completely, I can’t acces it. I think I have to reinstall the whole thing from scratch.

No, that’s very likely to be unnecessary.

Are you using a reverse proxy? Or Cloudflare? Both can interfere with Let’s Encrypt setup.

Were there any errors after the rebuild?


Thanks again, sorry for the late reply, but at the time you’ve sent that message, it was already midnight over here. Anyway, I don’t use cloudfare or reverse proxy, I just rebuild it again and it complained that the domain was already in use and that it would be better that I switch Let’s Encrypt off.

That usually means that your DNS is not configured right.

My guess is that you have have two A Records. Can you share your url?

Thanks it’s, endeavouros com and the subdomain is

 dig +short

Clicking the above URL takes you to

You haven’t set the hostname in your app.yml. It would appear that you didn’t run discourse-setup as recommended above.

I don’t understand why the IP address doesn’t match your hostname. Are you using a DigitalOcean floating IP?

That’s strange, because the last IP adress is my DigitalOcean IP. The first IP isn’t known to me.
I don’t use a floating IP adress and now, I’ve tried to install Discourse with the bitnami pack, that’s why it appears that I didn’t set it up right.The first few times, I did instal it as mentioned earlier.