Unable to connect WordPress site to Discourse

@Simon_Cossar
I use your plugin but I have a problem. I’m waiting for your help. My problem is this. [Discourse_topics] running on localhost does not work on my server. [Discourse_link] works on my server, but [Discourse_topics] don’t. All settings of my server are the same with localhost. What could be the reason?

localhost ss: Screenshot by Lightshot
my server ss: Screenshot by Lightshot

On the WP Discourse Connection options tab, make sure you have entered your Discourse All Users API Key and set the Publishing Username to ‘system’. Also, make sure the “You are connected to Discourse” message is displayed at the top of that settings page.

Are the topics on your Discourse site in protected categories? If so, have you selected the “Display Private Topics” option from the WP Discourse Shortcodes options?

1 Like

API connection has been successfully established on localhost. But even if I don’t establish api connection, the shortcode works successfully. I was unable to connect to the API on my server. I am writing the correct API code. I am writing Discourse Admin user but connection cannot be established.

Warning I received note: You are not connected to Discourse. If you are setting up the plugin, this notice should go away after completing the form on this page.

I caught the errors in the screenshot with the Querymonitor plugin: Screenshot by Lightshot
Curl 7.58.0 is installed and running on my Wordpress server. Everything is fine when I run the curl google.com command with SSH. But when I run my forum address, I get “cURL error 6: Could not resolve host: forum.address.com” error.

@Simon_Cossar

1 Like

That will be the problem. The plugin will not work unless you can fix that issue.

How can I solve it? Can you help with this problem? @Simon_Cossar

I can try, but the issue is probably related to your WordPress site’s server. Can you have a look at topics in #support:wordpress to see if any of them relate to your problem? The advanced search page might be useful. Try starting with a search like this: Search results for 'curl error ' - Discourse Meta.

1 Like

discourse works properly when I make requests to other websites with curl command. I’m just having trouble connecting to my site. Is it because I use the same domain? like this: the forum I want to connect to: discourse.domain.com
wordpress: domain.com @Simon_Cossar

That will not cause problems.

I’m fairly sure the issue with the error “cURL error 6: Could not resolve host is related to your WordPress site’s configuration. Is your WordPress site on shared hosting, or is it on a server that you have configured yourself?