Unable to merge users after SSO switch

[ Me again. ]

When we switched to SSO, we discovered one of our users used separate email addresses for WordPress and Discourse, resulting in his having two accounts. And now that he’s used both, things are a little messy.

User says:

Duder… I’m having trouble getting PajEvo logged onto the forum. Tried a PW reset but it doesn’t recognize my user ID. Tried using other email adds but doesn’t like em. I can get in under JDM journeys but that isn’t my primary acct and I don’t like to have two running and active. That’s why I’ve been kinda mute lately. I’ve got stuff to share but don’t wanna be posting it under my editorial name/acct.

I’ve tried doing the rake/merge thing in console, but it looks like I’m missing a rake file or something.

Any advice? I feel like I’m missing something really simple.

Here’s a screenshot from the console.


  • PajEvo is the original Discourse account, now locked out by SSO.
  • JDMjourneys is the WP account forced by SSO.

Thanks as always. Really appreciate this community. :slight_smile:

1 Like

Any advice on merging users here @Joshua_Rosenfeld?


@pfaffman rando thought: Could this be related to our dual-container setup?

(I know I saw you’ve had some issues with merge task, not sure if this is relevant.)

Thanks, all.

You’re running the rake command outside of your container. You forgot to do ./launcher enter app first.

1 Like


What you left out of your screen shot is

./launcher enter app
Config file was not found, ensure containers/app.yml exists

Available configs ( ...  web_only ... )

You need to do a

./launcher enter web_only

rather than app.

I updated my instructions at Managing a Two-Container Installation - Documentation - Literate Computing Support to make this more clear.

It’s almost always better to paste the text from a terminal rather than a picture of one…


@TGP, are you all set here? Jeff pinged one of my test users (which I’ve now deleted), so I didn’t see this mention. Apologies.


Oh man. That did the trick. Worked flawlessly, on the first try.

Thank you all so much for helping. I am blown away.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.