Unable to rebuild app - Possible Data Explorer plugin issue?

Hi everyone,

My Discourse is 2.6.0.beta2 ( 5d7055779a )

I’m having problems trying to rebuild my Discourse via command line with a ./launcher rebuild app command.

It seems to go through the motions correctly, then exits with:

/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/activerecord- `migrate'
/var/www/discourse/lib/tasks/db.rake:215:in `block in <main>'
/var/www/discourse/vendor/bundle/ruby/2.6.0/gems/rake-13.0.1/exe/rake:27:in `<top (required)>'
/usr/local/bin/bundle:23:in `load'
/usr/local/bin/bundle:23:in `<main>'
Tasks: TOP => db:migrate
(See full trace by running task with --trace)
I, [2020-09-05T08:25:58.657559 #1]  INFO -- : == 20200810053843 CreateDataExplorerQueries: migrating ========================
-- create_table(:data_explorer_queries)
   -> 0.0106s
-- create_table(:data_explorer_query_groups)
   -> 0.0094s
-- add_index(:data_explorer_query_groups, [:query_id, :group_id], {:unique=>true})
   -> 0.0027s

I, [2020-09-05T08:25:58.658141 #1]  INFO -- : Terminating async processes
I, [2020-09-05T08:25:58.658212 #1]  INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/12/bin/postmaster -D /etc/postgresql/12/main pid: 49
I, [2020-09-05T08:25:58.658286 #1]  INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 166
166:signal-handler (1599294358) Received SIGTERM scheduling shutdown...
2020-09-05 08:25:58.659 UTC [49] LOG:  received fast shutdown request
2020-09-05 08:25:58.660 UTC [49] LOG:  aborting any active transactions
2020-09-05 08:25:58.666 UTC [49] LOG:  background worker "logical replication launcher" (PID 58) exited with exit code 1
2020-09-05 08:25:58.667 UTC [53] LOG:  shutting down
2020-09-05 08:25:58.683 UTC [49] LOG:  database system is shut down
166:M 05 Sep 2020 08:25:58.719 # User requested shutdown...
166:M 05 Sep 2020 08:25:58.719 * Saving the final RDB snapshot before exiting.
166:M 05 Sep 2020 08:25:59.567 * DB saved on disk
166:M 05 Sep 2020 08:25:59.567 # Redis is now ready to exit, bye bye...

Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 3035 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"db_migrate", "cmd"=>["su discourse -c 'bundle exec rake db:migrate'"]}
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.

The site still works (thankfully!).

If I remove the Data Explorer plugin then the site rebuilds correctly.

As soon as I add the Data Explorer back in to app.yml it fails to rebuild the site.

The relevant sections of my app.yml look like this:

## Plugins go here
## see https://meta.discourse.org/t/19157 for details
    - exec:
        cd: $home/plugins
          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/discourse/discourse-solved.git
          - git clone https://github.com/paviliondev/discourse-locations.git
          - git clone https://github.com/merefield/discourse-onebox-assistant.git
          - git clone https://github.com/discourse/discourse-data-explorer.git          
## Any custom commands to run after building
  - exec: echo "Beginning of custom commands"
  ## If you want to set the 'From' email address

Any advice please?

1 Like

Similar to?:


Possibly :thinking:

If I run the query you have there, I get these results:

But to be perfectly honest, I’m way out of my depth here and don’t know if this is good or bad, nor, what to do next :grimacing:


Identical - Thanks @merefield

Sure enough, I ran the query you shared in your other post and saw a few duplicated data explorer queries.

I took the plunge and I did as you did, DELETEing the higher ID numbered ones, keeping the lower numbered ones in place.

Added the Data Explorer plugin back to my app.yml and it rebuilt perfectly with no issues or errors.

Thanks again :bowing_man:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.