Unable to select/enter pin topic date in IE 11


(Tom Spilman) #1

So I go to pin a topic and it seems now a date is required to pin any topic. I’ve tried a bunch of different date formats and so far I’ve not been able to work out what it needs from me. It continuously tells me “A date is required to pin this topic.” regardless of what I enter in that box.

Am I missing something obvious? Do I maybe have something misconfigured?


(Joshua Rosenfeld) #2

Are you talking about this modal?


If you click one of the time boxes, a small calendar should appear. Does it not?


(Tom Spilman) #3

It does not… in fact I get a text edit cursor like I was hovering over a text box when I hover over the time icons.

I’m running IE 11 in this case.


(Joshua Rosenfeld) #4

I can reproduce this on Stonehearth in IE11. Seems to be browser specific, Chrome works fine, so does Firefox.


(Tom Spilman) #5

I just ran it in Chrome and see how it should be working. It does look like this is broken in IE 11.


(cpradio) #6

Just for others who may stumble on this. The date format is yyyy-mm-dd


(Tom Spilman) #7

It doesn’t seem to accept it being typed in IE 11, but it does work in Chrome.


(cpradio) #8

Okay, I’ve updated the topic title to reflect that. I unfortunately do not have the ability to run IE 11.


(Jeff Atwood) #9

Out of curiosity, does it work in Edge?


(Joshua Rosenfeld) #10

All good in Edge here…


(John Babich) #11

Just reporting a bug I hit today but on twittercommunity.com I was not able to get the calendar entry for Pin Topic to work at all with fully up to date Google Chrome on Mac OS X. Actually it wasn’t working even if I tried a bunch of date formats (including like 2016-03-02) so I ended up having to fire up Firefox.

Thanks,

John


(Sam Saffron) #12

@zogstrip can you have a look at this?


(Régis Hanol) #13

Weird, I just tried and it worked. Can you tell me more about what you did?


(John Babich) #14

Ok I was just trying to pin a topic I had made to Advertiser Tools and APIs - Twitter Developers and it wasn’t showing calendar upon clicking within the box and wasn’t accepting any date I entered.

I technically have a gazillion tabs open and haven’t rebooted in a while so might be worth me completely closing out Chrome and seeing if it still repros.


(Sam Saffron) #15

Is this still happening anywhere?

cc @jomaxro


(cpradio) #16

Yes, still happens for IE 11 on my sandbox (which was updated yesterday). I don’t get the calendar pop-up to select a date for the pin topic and pin topic globally.

No idea if this helps any (or if it is related)

Edit: I think that console message is related as it only appears when opening the Pin Topic Modal.


(Sam Saffron) #17

OK, looks like it is this line

this._picker = new Pikaday(Object.assign(default_opts, this._opts())); 

Object.assign is not supported on IE11, should be very simple to fix.

> Object.assign({a: 1, b: 1}, {a:2})
< Object {a: 2, b: 1}
> _.merge({a: 1, b:1}, {a:2})
< Object {a: 2, b: 1}

(Sam Saffron) #18

Does this fix it?


(cpradio) #19

Yay!

And pinning works, selecting a date and choosing to Pin Topic works in IE 11, I did test it end to end :slight_smile:


(Jeff Atwood) #20