Unclickable "Read More" button in excerpt

Dear all,

Thank you @david for suggest me to create new topic in #ux here.

The problem is when user include a large image or header in beginning of a new Topic, the “excerpt” and “Read More” become no longer clickable.

It is because discourse generate lightbox for the image and anchor for header. The <a> tag included in excerpt break the link.

<a class=\"lightbox\" href=\"\" data-download-href=\"\" title=\"Image title\"></a>

and

<a name="header" class="anchor" href="#header"></a>

Here is screenshot from Chrome inspector.
2021-11-23_185623

And this is a screenshot from latest.json

2 Likes

I tried to reproduce this locally, but I can’t. If I include a lightboxed image at the beginning of the post, it simply skips the lightbox/link, and shows the text below:

Screenshot 2021-11-23 at 11.48.56

Can you share the ‘raw’ markdown for the post which has the issue?

Also, can you share your values for the relevent site settings:

I tried another discourse testing site.
The post only have one image and then text.

Link

https://icute.jp/

Site Setting:
2021-11-23_203850

In the Chrome Inspector, span class “topic-excerpt-more” have no <a> tag around it, that is why the “read more” button cannot be clicked.

Here is the latest.json