UNEXPECTED ERROR 500 5.0.0 - no-Email sending

Hi
I installed discourse:

  • following the offical 30min tutorial
  • Ubuntu 20.04
  • I get to the “Congratulations, you installed Discourse” screen
  • I can register and it says that it sent an e-mail - but no e-mail reaches my inbox
  • also not, when I click “resend activiation”

What I tried according to the "troubleshooting email on a new discourse install):

  • Telnet: connection is ok (connected and service ready)
  • discourse doctor: “UNEXPECTED ERROR 500 5.0.0 Unknown or unimplemented command.” …This is not a common error. No recommended solution exists. Please report the exact error message above to h ttps://meta.discourse.org/
  • e-mail provider logs: there is nothing visible, that an e-mail would have been sent
  • Discourse Log:

Apache
root@ubuntu-2gb-fsn1-3:/var/discourse# tail shared/standalone/log/rails/production.log
lib/middleware/enforce_hostname.rb:23:in call'* *lib/middleware/request_tracker.rb:177:in call’
Rendered exceptions/not_found.html.erb within layouts/no_ember (Duration: 0.5ms | Allocations: 137)
Rendered layout layouts/no_ember.html.erb (Duration: 8.0ms | Allocations: 1280)
Rendered html template (Duration: 0.0ms | Allocations: 2)
Rendered layouts/email_template.html.erb (Duration: 0.3ms | Allocations: 30)
Delivered mail 8731fbdf-b6c8-49b5-86d5-08d8c32e5ac1@talk.absolutum. net (485.7ms)
Job exception: 500 5.0.0 Unknown or unimplemented command.

  • E-Mail Domain
    • My domain is: talk.absolutum. net
    • the e-mail sending domain is: norepoy@absolutum.net (so this is different from the domain
    • therefore I uncommented the "-exec: rails r “SiteSEttings.notification_email…” and entered my e-mail in the app.yml
  • I rebuild the app
  • I also changed the sitesettings.notification e-mail via the command line
  • I tried to use with or without TLS (in the yml) and port 587 and 25 (both ports are supported by my e-mail provider (also with rebuild)
  • I have no IP Adress in the mail domain
  • Results of the discource doctor:
    ==================== MAIL TEST ====================
    For a robust test, get an address from h ttp://www.mail-tester.com/
    Or just send a test message to yourself.
    Email address for mail test? (‘n’ to skip) [info@absolutum.net]:
    Sending mail to info@absolutum.ne t. . .
    Testing sending to info@absolutum.ne t using smtp .socketlabs.com:587, username:server34665 with plain auth.
    ======================================== ERROR ========================================
    UNEXPECTED ERROR
    500 5.0.0 Unknown or unimplemented command.
    ====================================== SOLUTION =======================================
    This is not a common error. No recommended solution exists!
    Please report the exact error message above to h ttps://meta.discourse.org/
    (And a solution, if you find one!)

Any idea, what I could try to solve the problem would be appreciated.
(sorry as new user I was only allowed to use 2 links, to I had to put some spaces in some urls)
Thanks
Olivier

Doh! I missed that. Since discourse-setup now asks for this that note is meaningless. Jeff, I’ll try to submit a PR removing that next week.

Did you put the proper address in discourse setup when it asked? Did you not understand the question? (which i can’t find the exact verbiage for now from my phone).

But that error is very strange, so I rather doubt that the notification email is the issue. What is the mail server? It shows no connection in its logs?

Thanks Jay for your reply.
Well, that’s what I entered (I removed user and password for mailer and the maxmind license key)
Does this look right?

Hostname : talk.absolutum.net
Email : info@absolutum.net
SMTP address : smtp.socketlabs.com
SMTP port : 587
SMTP username : myUsername
SMTP password : myPassword
Notification email: noreply@absolutum.net
Let’s Encrypt : info@absolutum.net
Maxmind license: license-text