Upgrade stuck on bundle exec rake multisite:migrate


(Vaping Community) #1

I tried to implement the latest upgrade

Upgrade is hanging on bundle exec rake multisite:migrate

Not sure what to do to fix this, clicking reset upgrade gives me this warning.

warning

Thanks in advance


(Vaping Community) #2

I ran ./launcher rebuild app and that seems to have solved the problem

Refer to this quote for the correct fix.


Stuck on "bundle exec rake multisite:migrate"..help
Stuck on “bundle exec rake multisite:migrate”..help
#4

Had the same issue on both my sites (yes I know, should do them one by one to reduce risk … )


#5

OK I did ./launcher rebuild app and the site returned fine

I then performed:

./launcher cleanup

But then when I checked the upgrade page I found:

I have the same issue on my other site:

Hmmm … can’t leave it like that?

It’s now impossible to Upgrade from the website as it will lead you to this blank console which appears to be doing nothing:

How to recover/reset this so future upgrades can be performed from /admin/upgrade?

This does not apparently resolve with an additional rebuild.


(Alan Tan) #8

I’ve reverted the commit for now but do note that the upgrade was completed but “upgrade is completed” message from the server failed to reach the client in this case. I’ll probably need to run the upgrader in another process for us to support post deploy migration in docker_manager


#9

Still getting this after a ./launcher rebuild app


(Alan Tan) #10

Can you click on currently upgrading... and click on the cancel upgrade button? It should reset the state of the upgrade process.


#11

Ha, this didn’t appear to work last time, but now does, apologies! All reset and normal now, thank you!


(Vaping Community) #12

This fixed it for me also, thanks :smile:


(Jeff Atwood) #13