Upgrade with discourse-tagging plugin failed, website down


(Uwe Keim) #1

Tried to do an upgrade through the web UI, it failed.

I then did the usual

cd /var/discourse
git pull
./launcher rebuild app

but it also failed (discourse-upgrade-failed.txt):

** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

I’ve found this error, scrolling up.

NoMethodError: undefined method `attributes’ for TopicListItemSerializer:Class

Now my website is down and I’m really clueless.

My question:

How to approach this and bring my website back online again?


(Jonathan Pautsch) #2

I’m curious, do you have the discourse-tagging plugin installed? Can you scroll up in the output and see if you spot any other errors?

Like this one:


(Uwe Keim) #3

Yes, the discourse-tagging plugin is installed.

I’ve attached the whole output and found:

NoMethodError: undefined method `attributes’ for TopicListItemSerializer:Class


(Jonathan Pautsch) #4

Yeah you’re getting the same error I am. The latest changes to the tagging plugin seem to have broken my instance. I have temporarily disabled the tagging plugin and was able to build successfully.


(Uwe Keim) #5

Thanks. My post seems to be a duplicate of your post


(Robin Ward) #6

I’ve fixed this issue in the tagging plugin and it’s now compatible with our stable/beta branches again without failing:

https://github.com/discourse/discourse-tagging/commit/04513d372c386a741aa63c3bca7db90784dabb40

@sam we should discuss why I think the extend APIs I baked in there are a good idea – it would have prevented this issue for example.


(Uwe Keim) #7

Works again, thank you for your fast help.


(Régis Hanol) #8