[Error] Can't create a tag on post due to Tickets plugin

My forum recently does not allow me to add a tag. It says internal error after the update.

image

I have no required tag groups.

1 Like

This happened to me on my test site yesterday. Unfortunately I didn’t check for errors in the console for a repro before I did a ./launcher rebuild app. However, a rebuild fixed it for me. :+1:

1 Like

No I still have the error even after a rebuild. Here is the backtrace of the error log.

NoMethodError (undefined method `id' for #<Array:0x00007f86479e85e8>) app/controllers/tags_controller.rb:249:in `search' app/controllers/application_controller.rb:404:in `block in with_resolved_locale
Message (149 copies reported)

NoMethodError (undefined method `id' for #<Array:0x00007f86479e85e8>)
app/controllers/tags_controller.rb:249:in `search'
app/controllers/application_controller.rb:404:in `block in with_resolved_locale'
app/controllers/application_controller.rb:404:in `with_resolved_locale'
lib/middleware/omniauth_bypass_middleware.rb:71:in `call'
lib/content_security_policy/middleware.rb:12:in `call'
lib/middleware/anonymous_cache.rb:368:in `call'
config/initializers/100-quiet_logger.rb:23:in `call'
config/initializers/100-silence_logger.rb:31:in `call'
lib/middleware/enforce_hostname.rb:23:in `call'
lib/middleware/request_tracker.rb:202:in `call'

Backtrace

plugins/discourse-tickets/plugin.rb:47:in `block in filter_allowed_tags'
plugins/discourse-tickets/plugin.rb:47:in `select'
plugins/discourse-tickets/plugin.rb:47:in `filter_allowed_tags'
app/controllers/tags_controller.rb:249:in `search'
plugins/discourse-custom-wizard/lib/custom_wizard/extensions/tags_controller.rb:7:in `search'
actionpack (6.1.4.7) lib/action_controller/metal/basic_implicit_render.rb:6:in `send_action'
actionpack (6.1.4.7) lib/abstract_controller/base.rb:228:in `process_action'
actionpack (6.1.4.7) lib/action_controller/metal/rendering.rb:30:in `process_action'
actionpack (6.1.4.7) lib/abstract_controller/callbacks.rb:42:in `block in process_action'
activesupport (6.1.4.7) lib/active_support/callbacks.rb:117:in `block in run_callbacks'

Env

HTTP HOSTS: forum.duelistsunite.org

Seems to be a problem with discourse tickets. I’ll remove that and rebuild.

1 Like

Hmmm. Yes. Now you mention it… I did actually remove that plugin during my rebuild as a ‘while I was there’ job, but didn’t click it was connected. In hindsight, that would have been useful information to share. :man_facepalming:

It works now after rebuilding without discourse tickets.

1 Like

@angus should we move Tickets Plugin 🎟 to #plugin:broken-plugin ?

Yes, I think that’s appropriate. I’ve moved it. It’ll motivate me to fix it.

4 Likes