Upgrading Ember to 2.10

Seems like another unrelated bug to Ember, but I fixed anyway:

https://github.com/discourse/discourse/commit/40c944cb36ef239cf9db1539174cbd005eaddba2

4 Likes

I’m happy to report that as of an hour ago or so, Ember 2.10 has been merged into Discourse! Keep reporting bugs as you find them please.

9 Likes

After upgrading to the latest Version, using git pull and rebuild app, it still says my installation is outdated. No errors or anything in the Logfile. No Update if I click on the notification.

A click on compare shows:

https://github.com/discourse/discourse/commit/ddd299f4aaf25353cc2f47829d213623a3cf7590

I’m not not not sure I can keep up. When will the inclusion of ember-2.10 be stabilised on master?

Hehe, this is epic. Thanks for keeping the patches coming!
I hope for a final Revert "“Revert “Revert “Revert Ember 2.10+ for a short while””” :heart:

It has been a terrible situation, I’m sorry. We are having some operations issues that required us to roll it back a few times. Since it’s the weekend and I have to go away I imagine I’ll merge it back in on Monday, and then we’ll keep it for good.

8 Likes

I’m staying off the bleeding edge until you guys sort things out, here’s to hoping for a smoother upgrade next week!

I’m no admin on meta, but consider yourself awarded the revertbatum badge for having the most reverted commit :trophy:

1 Like

Honestly, no worries, I can’t even begin to imagine the headache that upgrading involves on your part. Good luck, and I look forward to some Ember 2.10 goodness hitting master early next week!

4 Likes

Also, for who’s coding against new ember, the revert had nothing to do with newest ember, so you can prepare your code without worries.

12 Likes

Ember 2.10 is in at last!

9 Likes

This bug/issue is back after upgrading to Ember 2.10. With the revert it was gone.

I can repro that (and the table misalignment bug) on my instances @eviltrout

1 Like

This upgrade seems to have broken https://github.com/techAPJ/discourse-topic-group-button again @techAPJ (Sorry)

I’ve fixed the plugin for the new connector API but you’ll want to update your discourse to point at this new repo location instead.

edit: replied to wrong person, was meant for @carlokok

4 Likes

It seems raw templates in plugins are being registered with javascripts/ in front of their name. This is what Discourse.RAW_TEMPLATES looks like when I run Topic List Previews.

This means that existing templates are not being overridden. And that new plugin templates cannot be (easily) used.

It is possible to reopen the relevant class and update the buildBuffer method, e.g.

      buildBuffer(buffer) {
        const template = findRawTemplate('javascripts/list/topic-list-item');
        if (template) {
          buffer.push(template(this));
        }
      },

This works, but is not ideal. In terms of referencing my own raw templates, I tried just including javascripts/ e.g.

{{raw "javascripts/list/topic-thumbnail"}}

However this was parsed as:

1 Like

I’ve fixed the docker_manager issue:

https://github.com/discourse/discourse/commit/16b236899c11977f73fbe851ae04d863179a9565

4 Likes

This commit should help with that:

https://github.com/discourse/discourse/commit/da4e27ca7dd8e0706566c0165db8211217a7bde6

5 Likes

Thanks! I’ve got TLP working again with this. This fix works well for template helpers, i.e. I can now just use {{raw "list/topic-thumbnail"}}, however, I still need to override buildBuffer to use javascripts/list/topic-list-item instead of list/topic-list-item (see here). Easy enough to do. Will this be the standard going forward, or a temporary measure?

1 Like

Aha, in that case perhaps we just prioritize javascripts/ for raw templates:

https://github.com/discourse/discourse/commit/1be800b673dc9b42e6ae0767971a6c2d8e096df7

I think with that it should work without overriding it.

7 Likes

Yup, that did it :slight_smile: Thanks.

1 Like