Uploading animated gif to user card - No Animation


(Stephen Kerr Jr) #1

I am on the most recent update v1.4.0.beta11 +172. I have seen a few forums including Meta that allows animated Gifs in the user card. I attempted to upload several different GIFs as a user card background, but they all come in as still images. Is there anything special i need to do? i even played around with these settings to no avail:
download remote images to local
create thumbnails
allow animated avatars
allow animated thumbnails

nothing seemed to fix the issue. Any ideas?


(Régis Hanol) #2

Have you tried uploading another GIF?


(Stephen Kerr Jr) #3

yeah i have tried about 5 different GIFS, uploading before and after these options were enabled. nothing really helped.


(Stephen Kerr Jr) #4

I just uploaded a GIF here and it did the same thing. No animation. This is the origional GIF


(Régis Hanol) #5

Can you leave “allow_animated_avatars” enabled and upload a GIF you have never uploaded yet?


(Stephen Kerr Jr) #6

Avatar would just be your little round icon. I havent tried that yet, but i am mainly talking about user card. I will give it another shot with a smaller gif and that option on.


(Kane York) #7

No, do a normal sized one, but make it a different file. Any edit will do.


(Stephen Kerr Jr) #8

After the image is uploaded, i check it out and i can find the URL path to the image that was just recently uploaded and not showing animation. This is the link to the most recent image i uploaded. It is no longer animated:


(Stephen Kerr Jr) #9

Discourse is definitely removing the animation factor of these GIF images I am uploading.
The only option on the “Files” tab that is different from the default is: allow animated avatars. and this is set to allow (checked).

The same thing is happening here on Meta. I uploaded a GIF to my user card. after checking the link to where that GIF goes, it is just a still image.


(Sam Saffron) #10

As @zogstrip said:

Can you leave “allow_animated_avatars” enabled and upload a GIF you have never uploaded yet?


(Stephen Kerr Jr) #11

yes i just did that. it is still coming in as a still image. no love. Does “allow_animated_avatars” also allow gifs for user card backgrounds and profile backgrounds?


(Sam Saffron) #12

Did you upload a different animated image ?


(Stephen Kerr Jr) #13

Yup, just downloaded a random waterfall gif and tried to use that. no love. still a “still” image when uploaded as my user card background.


(Stephen Kerr Jr) #14

Even the user icon avatar as an animated GIF does not work.


(Jeff Atwood) #15

Possible there was a regression here @zogstrip?


(Stephen Kerr Jr) #16

your the one responsible for my obsession for a GIF user background @codinghorror ! haha


(Ryan) #17

Bump… I am also not able to get animated user cards and profile pictures to work.


(Jeff Atwood) #18

Can we see if we can fix this before release @zogstrip? At least when animated stuff Is allowed in site settings?


(Régis Hanol) #19

Yes, I will have a look first thing :fr: Monday morning.


(Régis Hanol) #20

Here’s the fix :crocodile:

Was because the tempfile path we get from Rails was not including the extension of the filename and thus disabling all GIF support when optimizing the images.