Verifying users who can't click their verification email


(Joakim Bang Larsen) #1

I have a user with some accessibility challenges.
She uses a text-based browser and email system because of visual impairment.
Therefore she has problems “clicking” the verification email.
Will she get stuck with my email adress for the mailing list option if we use my email adress to verify her?

EDIT:
I first tried to use my own email adress to verify her, and then have her forward the verification email to me, but there was a lot of hickups with the former method and with the latter method I got the error message “There was an error changing your email address. Perhaps the address is already in use?” when I tried to click the link for her.


#2

Hi Joakim,

You can manually activate her account in the Users section of the Admin panel.
Jump into her profile to find the “Activate Account” button.


(Matt Palmer) #3

I’m curious about what it is that’s preventing her from clicking the verification email? Is the email we send not accessible to visually impaired users, or is it a fundamental limitation of her choice of technologies that it can’t handle links in emails, and they’d have to be manually typed into a browser (which I can imagine would not be a pleasant experience)? If the latter, are there any alternative methods of email validation we could employ to make this user’s environment able to participate?

In other words, what could Discourse do better to make this experience more palatable for this particular user?


(Jeff Atwood) #4

This is especially odd since the verification emails we send are extremely simple, basic HTML with a hyperlink and there is a plain text payload like there is on all our emails…

----==_mimepart_597283d8b8960_773fd00a24cee8136ba
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 7bit

Welcome to Demo!

Click the following link to confirm and activate your new account:
http://try.discourse.org/u/activate-account/bed0552f2081449f921e8763990e6bbd

If the above link is not clickable, try copying and pasting it into the address bar of your web browser.

----==_mimepart_597283d8b8960_773fd00a24cee8136ba
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: 7bit

<p>Welcome to Demo!</p>
<p>Click the following link to confirm and activate your new account:<br>
<a href="http://try.discourse.org/u/activate-account/bed0552f2081449f921e8763990e6bbd" target="_blank">http://try.discourse.org/u/activate-account/bed0552f2081449f921e8763990e6bbd</a></p>
<p>If the above link is not clickable, try copying and pasting it into the address bar of your web browser.</p>
----==_mimepart_597283d8b8960_773fd00a24cee8136ba--

(Felix Freiberger) #5

Perhaps she isn’t stuck on the link in the email but the JavaScript button on the follow-up confirmation page?


(Eli the Bearded) #6

Do you know which one? They are not all created equal, and many that I have used will only handle Discourse in read-only mode. edbrowse which I have used in the past for twitter has the best JS implementation of any text-based browser I know (it also has the worst interface for sighted people).

I just tried, and I cannot create an account on try.discourse.org or log into meta with edbrowse.

$  edbrowse https://meta.discourse.org/
122244
.
117
1,$p
<> <> <Log In secure>

Unfortunately, {your browser is too old to work on this site}.
Please {upgrade your browser}.
^D
EOF
$ 

(People who have used ed on Unix will recognize the interface. For everyone else it’s opaque at best.)

I gather that many people use screen readers these days, which presents a much different interface, and one Discourse will probably work better with.


(Joakim Bang Larsen) #7

I received this reply from my user who could not click the verification email:

“Joakin Bang Larsen, I’m delighted to share these things, and tried twice in my e-mails which got rejected by that site. The browsers are likely the main issue (I tried two on the site for that confirmation e-mail), but I’ll quickly cover the rest, too. I use a Pentium 4 (786) at 2.0 GHz, 256 M RAM, Slackware Linux 10, with elinks 0.11.5 and links 2.1pre28 as my main browsers. Note that elinks has ecmascript, while the links is the last release of which I know to support some Javascript. I have an ISP connection through ATT Uverse, which acts like my previous DSL as far as I can tell, but faster. I read mail online at my ISP using their Pine e-mail reader, which calls Lynx 2.8.x (I’m not sure of the exact version) to follow URL’s in an e-mail. When I received the confirmation e-mail (having been notified by e-mail of the username and password under which I had been registered), I tried following the link in Pine, which called lynx and got me to the site. When I reached the webpage, I saw a menu item: “Submit” with the text “Click here to activate your account.” When I moved the cursor to “Submit” and pressed [Enter] to click this item, I got the message (which I’m reading as I replicate the action): “**Bad HTML!! No form action defined. **” Apart from that message, nothing happened when I tried to activate that button or whatever. Then I decided to try manually entering the URL from that confirmation e-mail into elinks, hoping that maybe ecmascript support might make a difference. Accurately typing the arbitrary string of characters (presumably used to identify me as a user in confirming my registration) took a bit of time, but wasn’t too difficult when I typed groups of about five characters at a time. This got me to the site, and the same page with that confirmation button I had seen with lynx on my ISP. However, when I tried again after moving the cursor to that “Submit” button or whatever to click it by pressing [Enter], there was no result. I recall that maybe elinks showed it as a “Harmless Button” – which often means that something calling for Javascript won’t operate in elinks, I might guess. Anyone, that’s what happened – no problem getting on the site with lynx (called from Pine on my ISP) or elinks (on my own system, with the confirmation e-mail URL entered manually) – but no success with that “Submit” button.”


(Eli the Bearded) #8

Yeah, no version of lynx is going to work, I tried the links, elinks, and w3m versions I have currently installed, and none will handle the verification email page at all. edbrowse does the best, but that best means that it fails the browser Javascript compatibility test and gets the “Upgrade your browser” page.

Slackware 10 is rather old and that computer is rather underpowered for the GUI browsers that will (a) work with Discourse and (b) can be used with a screen reader. Mailing list mode is probably the only way that person will be able to use Discourse.


(Joakim Bang Larsen) #9

Ok thanks. After activating the user manually and turning on mailing list mode for her, my user is saying that she is now receiving emails from the forum but that she cannot reply to them.

When she tried to post an e-mail in response to one she received, she got this error message: “We’re sorry, but your e-mail message to To: ; (titled ) didn’t work. There was an unrecognized error while processing your email and it wasn’t posted. You should try again, or contact a staff member.”

Did she get that error message because her email adress is not yet verified?


(Matt Palmer) #10

I’m pretty sure there’s an explicit error for “you’re not verified”. Check your e-mail admin logs for more details as to what happened.


(Kane York) #11

Here’s the line in the translation file for that: discourse/server.en.yml at master · discourse/discourse · GitHub

It’s interesting that the received subject is an empty string, and the destination address is To: ; with the semicolon included. Maybe the e-mail client is generating something weird?