With Discourse AI summary allow option to create a summary, close topic and do not bump the date

Reset Bump Date would be used when a topic is bumped (either through editing the last post or receiving a reply). Resetting the bump date would change the topic’s updated_at back to its prior value and adjust its place in the Latest order back to where it was prior to the recent activity.

Changing a topic’s timestamp wouldn’t be recommended for this.

1 Like


I do see what you noted now that I have opened a post edit window.


Even after years of using Discourse and having admin rights and other levels on other sites, still learning.


1 Like

I agree that is a sledge hammer and not needed in this case.

1 Like

With this new info in mind, would the existing features be sufficient or are you still proposing an automated ai solution?

1 Like

Good question.

Doing a test on the OpenAI site and want to wait a day before trying the bump option from the editor.

Will get back to you on this but this looks to be a working solution. :slightly_smiling_face:


Gave Toggle topic bump a try and it did not work as I expected. May not have used it correctly but there is not a lot of ways to use it.

Open editor, click Toggle topic bump in list, enter text, click reply, check where the topic show up.

For me this the reply was at the top of the list as usual, even checked to make sure the topic was not at the top of the list before doing the test. :frowning_with_open_mouth:

That’s strange, it’s always worked when I’ve used it. Did you try the Reset bump date button after that?


I did not try that because the Toggle topic bump selection should have worked if that was its purpose. As I noted I have not used Toggle topic bump before so could be using it incorrectly.

Will give it a try again tomorrow when there should be more new post in the category and I can see where it lands in the list.

1 Like

I’ve tried it before and it’s always worked for me, so it’s odd that it didn’t work on your instance. Perhaps a recent commit broke it. I’ll check on my instance and report here. Can confirm, still works on my instance.


Just tested this again and it worked as expected.

This time I took more time to pay attention to the steps I did. One of the first steps is to decide which reply button to click and I did not consider that as significant the first time so did not record which one I did. This time I did and used the reply to the entire topic, or as some may think of it as replying to the first post.

It worked this time.

Will try again a few more times to make sure this is reproducible and try and figure out why I did not see it work the first time I tried it.

In another test noticed that the icon will change based on the selected action.

So need to see image in the upper left after a choice is made.


Used the two different reply buttons and both worked

So for now will take it that the test that failed for me was because the option was not set, which can be checked by looking for the icon.

Don’t want to consider this closed just yet but indicationars are good.


In the OpenAI site another user at TL3 and me at TL4 have been discussing the option Toggle topic bump; seems that as TL4 I have the option and they at TL3 do not have the option.

As a fan of

the entry Reset Topic Bump Date seems to confirm this.

1 Like

Did about another set of ~30 topics by hand and it worked as expected. One has to have the Toggle topic bump option as noted by @Firepup650 and check that it is set before posting by looking for image at the top left of the editor.

Since I forgot that a few times, those topics did get posted to the top of the list and I could find not way to fix that once the reply was made; really do like the admin option to just set any date and time on any post for such a problem but am not an admin for the noted site.

1 Like

I think the Reset Bump Date button in the topic controls should un-bump the post. If that’s not working, it’s probably a bug.

1 Like


Really like the use of Reset Bump Date

For those wondering how that is done.

<kbd>Reset Bump Date</kbd>

Just tried myself, that doesn’t seem to work after adding a post, but a workaround is to delete the post, then reset the date, and then restore the post.

How did you do that?

With the Reset Bump Date button :upside_down_face:

Made a human error so tried that.

When creating the reply again, after the deleted one, and closing the editor to post the reply was greeted with


So that does not work for my use case of creating summaries. :frowning_with_open_mouth:

I think undeleting the original should work, rather than reposting a new one.

1 Like

That did not work.

Does not give me the Reset Bump Date option.

Will not call it a bug but it would be nice if upon editing after posting the option was there.

I meant do this:

  1. Delete post
  2. Reset the bump date using the staff wrench
  3. Restore your post
1 Like