WP Discourse Plugin Slow Error comment-formatter.php:62

Hey team, I hope you are all doing well. The WP Discourse Plugin has been hugely helpful for me and my community. I just wanted to reach out to see if you might be able to help me with something.

Recently my Wordpress website myfishingcapecod.com has been having issues with the WP Discourse Plugin. The WP Discourse plugin is throwing thousands of slow errors which I can see in my server logs.

Today the errors were happening so much that my site went down. I was able to bring the site live by deactivating the WP Discourse plugin. I then tried deleting and re-installing the plugin but the issue persists.

I have copy/pasted an example of the error I am encountering below. If anyone knows of a solution then it would be most appreciated.

Thank you for a helpful plugin!

[05-May-2022 04:02:30]  pid 26235
script_filename = /www/index.php
[0x00007f3aed014440] flock() /www/wp-content/plugins/wp-discourse/vendor_namespaced/monolog/monolog/src/Monolog/Handler/StreamHandler.php:106
[0x00007f3aed0143b0] write() /www/wp-content/plugins/wp-discourse/lib/logs/handlers/file-handler.php:167
[0x00007f3aed014300] write() /www/wp-content/plugins/wp-discourse/vendor_namespaced/monolog/monolog/src/Monolog/Handler/AbstractProcessingHandler.php:34
[0x00007f3aed014280] handle() /www/wp-content/plugins/wp-discourse/vendor_namespaced/monolog/monolog/src/Monolog/Logger.php:283
[0x00007f3aed014160] addRecord() /www/wp-content/plugins/wp-discourse/vendor_namespaced/monolog/monolog/src/Monolog/Logger.php:614
[0x00007f3aed0140e0] error() /www/wp-content/plugins/wp-discourse/lib/discourse-comment-formatter.php:62
1 Like

Thanks for this report Ryan, we’re looking into this now and will give you an update shortly.


@Ryan_Collins1 @gizadev You’ve both experienced the same error recently (see also).

While we debug this further, we’re pushing a fix to remove the specific log call which seems to be involved, as it’s non-essential anyway (i.e. there’s no harm in removing it) (PR). Albeit it is unlikely to be the underlying cause of the issue. When you see version 2.4.2 of the plugin appear in your Wordpress admin panel, that will contain this temporary fix.

This part of the plugin that hasn’t changed in a while, which is part of the reason I was initially skeptical it was the cause of the issue. To help the debugging process could you share any other changes you’ve made to your Wordpress recently? Any updates you’ve made, new plugins you’ve installed or the like.

Ideally if you could share the download from the WP Discourse Logs admin panel with me via private message, in particular the “Meta” file which will give me some insight into your Wordpress environment, i.e. your PHP version and other plugins you have installed. Also, which WP Hosting provider are you with?


This doesn’t help a bit, but I don’t have any issues and I’m using the plugin in three different environments.

What I’m meaning is there can’t be any fundamentally wrong and the plugin is not broken per se, but it must be connected to other factors.

Make this anything easier? No, it can make fixing actually some degrees harder. Has OP major problems? Defenetly, and I’m not trying to rub salt in open wounds by telling I’m fine.


Thanks, that’s good to know. I’ve also been unable to reproduce it so far. Actually, could you also share your meta file from the WP Discourse Logs panel if possible (PM it to me)? It may be useful for comparison purposes.

1 Like

I had one error:

[2022-05-06 08:37:56] webhook_topic.ERROR: update_topic_content.response_body_error

No idea what this is, but it did not affect me in the meaning I didn’t see anything strange.

Will send meta-data shortly.


@angus thank you very much for the prompt reply. I have private messaged you the logs as requested. I’ll be standing by regarding next steps and updates. Thanks!

Just a note that this was issue was discussed further with Ryan via PM. The upshot was:

  1. The issue most likely is derived from an aspect of the environment common to @Ryan_Collins1 and @gizadev. Other plugins were seeing a similar issue on Ryan’s site.

  2. The relevant log call was removed in WP Discourse 2.4.2 which was released on 11 May.

If anyone sees this issue again, please let me know.