Wrong maximum size when uploading files


(Martin Duparc) #1

The current maximum size I have set up is 200MB. Uploading a file that is less than 200MB works fine but anything above fails, as expected. The issue I have is that the user is then presented with the following message:

Sorry, the file you are trying to upload is too big (maximum size is 10240kb)

Nginx is properly configured at 200m and the max image size kb and max attachment size kb are both set to 200000


(Joshua Rosenfeld) #2

Could the issue be related to this commit which was fixing the error message?


(Jeff Atwood) #3

Did you restart Discourse after changing that setting? It might be required.


(Martin Duparc) #4

I did a full app rebuild after changing the size. Again, file upload works properly, it’s just the error message that still display 10MB. I have entered the container and the internal nginx cont file is right at 200m


(Jeff Atwood) #5

Hmm sure @techapj can you follow up and see? Do we hard code this value in text?


(Martin Duparc) #6

It doesn’t look like it is hardcoded, at least not in the localization file.


(RĂ©gis Hanol) #7

We do actually. My bad. Will fix.

(cc @techAPJ)


(RĂ©gis Hanol) #8

Thanks @martinduparc for reporting this issue. Fix pushed :green_apple:


(RĂ©gis Hanol) #9

This topic was automatically closed after 2 hours. New replies are no longer allowed.