Wrong sending domain used


(stadja) #1

Hello guys,
I know it’s a common problem,
but I am searching everywhere and I can’t find any answer !!!

So here is the deal:

  • I am running v1.6.0.beta1 +394
  • My email configuration is:
    address smtp.sparkpostmail.com
    port 2525
    domain ltn.io
    user_name SMTP_Injection
    authentication plain
    enable_starttls_auto true
  • when I try to send an email with the test button, all I have is:
    [Sender] 550 5.7.1 Unconfigured Sending Domain <gmail.com>

My discourse.conf is:

db_name = bitnami_discourse
db_host = /home/ltn/discourse/postgresql
db_port = 5432
db_pool = 25
hostname = "discourse.ltn.io"
db_username = ******
db_password = "*******"
redis_port = 6379
redis_path = ******

smtp_address = "smtp.sparkpostmail.com"
smtp_port = 2525
smtp_domain = 'ltn.io'
smtp_user_name = 'SMTP_Injection'
smtp_password = '******'
smtp_enable_start_tls = true
developer_email = "*****@ltn.io"

Anyone can see a problem ? An explaination ? I have been trying to correct this for 2 days now !

Please help ? :slight_smile:


(Dean Taylor) #2

Check the following settings in admin:

  • notification email
  • reply by email address

(stadja) #3

Thank you !
You rock.

:heart_eyes_cat:

It was the notification email.
But why ?


(stadja) #4

Ok,
so now my test email are working…
but not my activation emails ?

I think they are simply not sent at all … I can’t find any trace of them anywhere.


(Jeff Atwood) #5

You must validate the domain

discourse.example.com

with your email provider. If you fail to validate that domain with your email provider you will have problems.

Also Bitnami installs are not supported here, only Docker based installs.


(stadja) #6

Dude seriously ?
I’m running v1.6.0.beta3 +12 from your github account, that should be sufficient no ?
The docker version is kinda hard for me to run because I already have an apache running on my server and so I know it is possible but there are plenty of things to do to make it run. With the bitnami install, it’s one ./ctlscript start and it works.

Anyway, my sending domain is validated. Other emails are sent correctly, but not the account validation notification. So it’s not usable… I’m kinda sad about this.

But thanks for your good work, I’m following this project for a long time now and I really like what you did.


(Felix Freiberger) #7

Yeah, it’s super complicated. Setting up the outer nginx instance takes two commands in the shell, and you’d have to actually copy and paste the configuration from the tutorial. You’d even have to change a line in you Apache config.

The :discourse: team is giving free support to open source users that aren’t paying them a dime. How careless of them to not support hard-to-debug unofficial installation methods, too…


(stadja) #8

Ok.

So:

  • This guide assumes you already have Discourse working : Ok so how is it possible. Because I can’t have discourse working because I already have an apache server running. When I try to install it, I can’t because the answer is something like: Your port 80 is already occupied, you can’t install it. => So, no my Discourse is not already working, I can’t install it.
  • Then, I want to use a docker container, in order NOT to install too many extra things on my production server. I don’t want to install an extra nginx server on my server
  • Finally: why would you answer me like that and who do you think you are ?

I never said they were careless nor anything, I am happy with their work, I am sad that it is not usable for me.


(Mittineague) #9

Ah, that wasn’t clear. I think the problem was seeing
db_name = bitnami_discourse
led others to think you were trying to do things your own way and then asking for help when you ran into problems.

Assuming you followed the Docker install


it would be helpful if you explained where that failed.


(stadja) #10

Well when I used the docker, I directly had an error:

$ ./discourse-setup
Port 80 appears to already be in use.

If you are trying to run Discourse simultaneously with another web
server like Apache or nginx, you will need to bind to a different port

See https://meta.discourse.org/t/1724`

(Felix Freiberger) #11

In that situation, you cannot use the discourse-setup script. Copy app.yml from samples to containers and fill in the values manually.
The tutorial includes changes to this file, which will ensure that Discourse can start up (listening on a socket).

After that, you can install nginx on your host and set it up to forward the subdomain for Discourse as explained in the tutorial. Your Apache installation will have to move to a different port so nginx can start up, and nginx will need some configuration to forward everything else to Apache as needed.

Any alternative using Apache directly as your front end HTTP server will have some performance issues because Apache deals poorly with long polling connections used by message bus.


(stadja) #12

Thank you for your answer.

I must say that I really don’t understand what in my current installation doesn’t work for sending emails !
I just received the “new version” notification by mail, with the good postmaster…
but when someone try to connect, he doesn’t receive the email (the good admin options seem checked) => those email sending doesn’t even appears in /admin/email/sent (nor bounced, ignored or rejected).

Grmbl.

Thank you for you time I’ll try to reinstall it from the beginning with an nginx later :slight_smile: