“Your topic is similar to” relevance search does not support Chinese/Japanese/Korean characters

After I enabling the search_tokenize_chinese_japanese_korean setting, I can search out topics with CJK characters. But it still cannot show up results in the “Your topic is similar to” area.

There was a recent fix

Thank you! However, I run discourse with GitHub - discourse/discourse_docker: A Docker image for Discourse, I login into the container and edited this file as the commit, but not working. What should I do?

Have you updated to latest from your [your site]admin/upgrade page?

It freeze, no upgrading progress. I directly edited the file in the container, is there some cache I should purge?

I’m afraid I’m not that great at unknotting install/upgrade issues. I haven’t come across someone editing a commit straight into the container before, so I’m unfamiliar if that’s even possible. :slightly_smiling_face: Hopefully someone else can jump in and offer some advice?

Is it the bug that’s not fixed? Or did you break your forum itself trying to update?

You could try rebuilding the app? ./launcher rebuild app

./launcher rebuild app works. Thank you!
To be precise, however, it still does not support CJK charaters, although the JS error disappeared.

1 Like

That’s good to hear. :slightly_smiling_face:

I wasn’t quite sure what you’d done, but usually I would update to latest from the admin/upgrade page in the first instance.

And if you do edit your app.yml at all, you’ll need to run ./launcher rebuild app for those changes to take effect. :+1: (eg. Installing a plugin, changing smtp address, etc)

It’s a shame that hasn’t solved your original bug query though.