Eventually I was able to use the phpBB3.3.3 dump file without defining the categories as new and without all the mapping in the settings.yml file.
With the original phpBB_mysql.sql dump file the migration script quits the step where categories are loaded and displays an error about “an empty category body”.
It occurs if the “forum_desc” field in the “phpbb_forums” table for the main forum categories (that don’t have parent categories).
After importing only that 1st category partially, the rest apparently becomes messed up.
Using a fresh installation and entering some text in the above table fields seems to solve this issue.