The discussion revolves around a failed Discourse installation due to plugin issues. barreeeiroo initially encountered an error while rebuilding Discourse with ./launcher rebuild app, which was later revealed to be caused by the docker_manager plugin being listed twice in the app.yml file, as pointed out by david.
After resolving this issue, barreeeiroo encountered another error related to the bundle exec rake db:migrate command, which was suspected to be caused by a Rubygems rate limit issue, as explained by elijah. Despite trying multiple times and manually installing the gems, barreeeiroo was unable to resolve the issue.
FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 502 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"bundle_exec", "cmd"=>["su discourse -c 'bundle install --deployment --verbose --without test --without development'", "su discourse -c 'bundle exec rake db:migrate'", "su discourse -c 'bundle exec rake assets:precompile'"]}
10e358782174bb619bcfda02feb0506c7e2daa2a25fc172ce07d57f625d2317d
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one
It’s our old “friend” Rubygems giving a 429 error.
Lots of people have been getting that, no one is quite sure why. Critically, it has not been happening for Discourse’s own builds, so it’s not something inherent in Discourse. The people at Rubygems have not been forthcoming with an answer. The recommended “fix” is just try again in a little while. And maybe complain to Rubygems.
Search for “rubygems rate limit” or “rubygems 429” for other topics on this.
I’ve also tried to install manually the gems that couldn’t be download inside the Docker container; they are installed with gem install x after ./launcher enter app but there stills download them automatically and showing 429 Error