3rd party plugins won't work (anymore)

Hi folks,
i added the following plugins to my discourse instance:

          - git clone https://github.com/discourse/discourse-spoiler-alert.git
          - git clone https://github.com/tcreativo/plugin_discourse_dynamic_sidebar.git
          - git clone https://github.com/joebuhlig/discourse-feature-voting.git
          - git clone https://github.com/angusmcleod/discourse-quick-messages.git
          - git clone https://github.com/discourse/discourse-solved.git
          - git clone https://github.com/discourse/discourse-pirate-speak.git
          - git clone https://github.com/discourse/discourse-cakeday.git                                                                                                                                                                                                                                                                                        

Unfortunally only the dynamic sidebar plugin was properblyworking with v1.7.0.beta6 +37 (cakeday not tested).
The messages plugin was there but didn’t show messages in the message box, only a green dot that was all.
Now i’ve updated to v1.7.0.beta6 +66 and nothing is working anymore - the settings in the admin panel are there,
enabling the sidebar doesn’t show anything, also the messages button is away.
Deleting plugins and tmp/, rebuilding, nothing helped, i am somehow out of ideas. :frowning:

@tchncs - are there any errors in the console? Looking at the Dynamic Sidebar Plugin warning #2 would concern me a lot. You may also be interested in the developer’s recent comment:

1 Like

Also @tchncs, we are undergoing a lot of work in the client side in order to update to the latest version of Ember.

Since the API changed, most plugins will break until the authors update them.

I would recommend that you disable unnecessary plugins until we’ve done migrating.


@jomaxro no, i tried a tail -f log/* but didn’t saw any errors.
I know about this warning but it worked anyway but i’ll check out the recommended blocks plugin, thanks.

@zogstrip thanks, that’s good to know. But i am curious on which state meta.discourse.org is since the solved plugin is working here. Do i have the wrong version? also with +37 i was unable to activate it. There was the checkbox in the admin settings to enable it global but without any effect, also there was no checkbox in the category settings.

Also i am curious about if it would be better to make the default branch of dicourse the release branch as it is on [diaspora*] (//github.com/diaspora/diaspora) for example since your tuturials are leading to master which contains the latest beta state as it seems like.

Meta always runs on tests-passed, this could be some other plugin breaking it.


Awww, looks like the pirate-speech plugin caused all the problems. :open_mouth:
(I thought it was just a locale?!)

Sorry for the trouble.