Rebuilding caused a JavaScript error on load


(Felix Freiberger) #1

After rebuilding my site a few minutes ago, Discourse no longer loads.

I get this error in the JavaScript console:

I’m down to these plugins, and the error is still there:

      - git clone https://github.com/discourse/docker_manager.git
      - git clone https://github.com/discourse/discourse-spoiler-alert.git
      - git clone https://github.com/discourse/discourse-data-explorer.git
      - git clone https://github.com/discourse/discourse-staff-notes

Disabling all site customizations did not help, too.

I’m out of ideas, and my Discourse instance is down :sadpanda:


I should add that I am running on the (latest) beta commit.


(Jeff Atwood) #2

Odd, I just rebuilt both discourse.codinghorror.com and talk.commonmark.org to latest, and they load fine with these plugins:

  • data-explorer
  • docker-manager

Plus spoiler and staff notes are used here on meta.

What’s the default language used there? Any unusual site settings?


(Régis Hanol) #3

Can you try without the spoiler-alert plugin?


(Gerhard Schlager) #4

Try removing the spoiler-alert plugin. It was updated today and I guess that change is not compatible with the beta branch.


(Felix Freiberger) #5

That worked (I haven’t singled it out yet, but removing all official plugins worked).

I’m adding all other plugins back in to check whether this is really the cause… :hourglass:


(Jeff Atwood) #6

This text will be blurred

Spoiler alert seems to be working ok here though.


(Felix Freiberger) #7

But you are probably running tests-passed, right?


(Jeff Atwood) #8

I see this is something for @tgxworld to look at.


(Felix Freiberger) #9

I can confirm this is caused by the Spoiler plugin. Thanks a lot, @gerhard! :slight_smile: