$4.5 Alicloud can't get discourse to work


(Sea) #1

Hello, @codinghorror
Let’s start with my renting server spec: $4.5 Alicloud 1gb RAM & 1 CPU

  1. My DNS A-record point to server public ip where I also use this ip for ssh.
  2. I follow this already discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub
  3. discourse setup
Hostname for your Discourse? **discourse.example.com<-- same as DNS **
Email address for admin account(s)? [me@example.com,you@example.com]: 
SMTP server address? [smtp.example.com]: 
SMTP port? [587]: 
SMTP user name? [user@example.com]: 
SMTP password? [pa$word]: 
Let's Encrypt account email? (ENTER to skip) [me@example.com]: 

After access URL ip only and discourse.example.com, it doesn’t connect me to admin setup page. I am very sad now and will sleep. Hope someone here can guide me through this infinite loop hole that I stuck in. Please!

** something worth mention: I believe I setup SMTP incorrectly, I can rebuild by fixing app file later, but first let get to the first setup welcome page first.

I am depressed. T_T

Sincerely,
Sea


(Jay Pfaffman) #2

Either you don’t know the IP or the ports are firewalled and nothing can connect to the server. You can try

telnet localhost 80


(Sea) #3

I guess we can solve it together so I can sleep better today. It returns this @pfaffman

Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Connection closed by foreign host.

For public ip, I run this in terminal:

dig +short myip.opendns.com @resolver1.opendns.com

There for I should have the public IP to do A-record in DNS service provider.
What do I did wrong? T_T


(Sea) #4

Any possible help from someone I am here now online ready to continue solving this please stop by and help will be much appreciated. LOVE!


(Bhanu Sharma) #5

Do you know the public IP of your server?
if so, Can you confirm if your A record is created correct?
At the very last, Are you hosting any other website on the same server?


(Sea) #6

@itsbhanusharma
Thank you for great great reply. I am waiting for someone here to help me fix in realtime. I have attached photo for clearer understanding. Am I doing it right?


(Bhanu Sharma) #7

So You’re managing dns from cloudflare.
I’m assuming your nameservers are successfully propagated and pinging discourse.example.com returns this same IP.

If all these above conditions are met, I’d be interested in checking the server itself if it has everything set up correctly. First step will be trying to check if server has the necessary ports open and if alicloud requires some additional rules to be created in your account to enable public access on ports 80 & 443.


(Sea) #8

@itsbhanusharma
I love discourse. I LOVE! We almost there I believe. Be with me sir! :heart_eyes:
1526879354308


(Bhanu Sharma) #9

I don’t think you have to add any address field access or authorization object.

Allow inbound access to SSH (22) HTTP (80) and HTTPS (443) that should suffice for now.

In the authorization object try something that represents more public (maybe 0.0.0.0)

Wait! Why does it says “Intranet” for NIC??

Ps: I did some homework for you and found this!
https://www.alibabacloud.com/help/doc-detail/65408.html?spm=a2c5t.11065259.1996646101.searchclickresult.623c6918aTGgwp

Turns out you need to set authorization object to 0.0.0.0/0 for public access.


(Sea) #10

@itsbhanusharma

Thank you you made my day! I have successfully open setup admin page for Discourse.
Now, I am working mailgun and forward it to gmail.

  • All Mx record, TXT record and, Cname is green status on mailgun.

Problem:

  • Sending email from outside domain to mailgun (custom-domain) mailgun server never forward it to my gmail. even though I setup route to forward to my outside mail correct and all DNS record are green.

Help me as you wish.!


(Bhanu Sharma) #11

can you give me an example of what you’re trying to achieve? I seriously can’t understand your issue!


(Sea) #12

@itsbhanusharma
I have successfully install discourse server + mailgun + gmail. It is the best of the best. Thank you!