WARNING: Port 443 of computer does not appear to be accessible using hostname: <mydomain>.com

app was not started !

./discourse-doctor may help diagnose the problem.

./discourse-setup: line 260: *0: syntax error: operand expected (error token is “*0”)

Hostname for your Discourse? [discourse.example.com]: .com

Checking your domain name . . .

WARNING: Port 443 of computer does not appear to be accessible using hostname: .com.

WARNING: Connection to http://.com (port 80) also fails.

This suggests that .com resolves to some IP address that does not reach this

machine where you are installing discourse.

The first thing to do is confirm that .com resolves to the IP address of this server.

You usually do this at the same place you purchased the domain.

If you are sure that the IP address resolves correctly, it could be a firewall issue.

A web search for “open ports YOUR CLOUD SERVICE” might help.

This tool is designed only for the most standard installations. If you cannot resolve

the issue above, you will need to edit containers/app.yml yourself and then type

./launcher rebuild app

I have couple questions :

  • I have .com and there is site already running . Now I want to run discourse as .com/discourse . The app is running in front of load balancer . But do i need to anything on discourse side

  • what port discourse is running ?

  • When i do curl I can reach to the site but why discourse setup is erroring out

  • is it ok ignore mail setup

1 Like

That should be your actual domain name, not just a TLD.


Not sure if it was replaced , but value is mydomain.com . I placed it between < and >

I could find port is 80

Hi there, Shibi

I’m still new here, but I runned into a similar situation last week. The easiest way to use your domain for two different servers is by using a sub-domain. You can do that by creating an A Record on your DNS provider specifying the hostname as sub-domain.your-domain.com, or just the sub-domain, and then point out the IP of the discourse instance.

This article may help with the above solution.

The solution I suggested above may help you with that. I think this way of using it as a resource for your other application may be harder to set up.

By using the official cloud setup script, it will run on port 80 by default.

Could you please give more details on that?

If you do so, you won’t be able to send any emails like invitations and account register confirmations. But probably you can’t ignore the smtp setup.

By the way, 443 is the HTTPS port, it is used to establish the encryption. This means your domain is probably not configured correctly and the Discourse setup is not being able to reach your server.


That’s the problem. Just type the full name with no spaces and no angle brackets.

And now your app.yml is broken. The easiest thing will be to

rm containers/app.yml

and start over.


I suspect he meant he placed it between <> in the post when he replaced his actual domain (see https://meta.discourse.org/raw/272567/1)


He said he is using this domain for another application, I believe the best way to go is setting up a sub-domain. Otherwise one would have to manually set up Nginx to serve both the prior app and Discourse in a resource route.

1 Like

yes - I was talking about post

Yes more thinking about solution thats Nginx , but wasn’t sure if its any internal config

Thanks @italo . I was able to solve most of issues currently stuck at mail config

1 Like

I’m glad I could help! :slightly_smiling_face:

For the email setup you will need an SMTP service, this tutorial has a list of the ones Discourse recommend. Although Gmail, Outlook and Yahoo have an SMTP option, they don’t support transactional emails, which is needed.