Add/Remove user on private discussion not available when creator

I ran into an issue on a Discourse forum I am quite involved with. We have several private discussions going with quite a few users being part of each discussion. I have so far not had any issues inviting new users to our discussions. That was until today when I tried adding/inviting a new user to one of our discussions. One discussion worked perfectly fine, but when trying to add to another, I couldn’t. There was no ‘Add/Remove’ button at the top overview, nor did the ‘share’ button at the bottom of the discussion show the option to ‘Send an Invite’.

After some further digging into this issue, I noticed that any of the discussions I am part of, but not created by myself, work perfectly fine. However, when being the creator of the discussion, I do not have the ability to invite or add users. These options just won’t show on my ‘own’ created private messages (discussions).

I have just tested the demo/sandbox as well, starting a message with ‘discobot’ with the same result, so it appears the issue is not specific to the Discourse forum I frequent, on which I am promoted to ‘leader’ (TL4).

Might want to look into this issue and hopefully get this resolved. Makes no sense to not be able to invite/add users to your own discussion (PM), after creation that is.

Regards, Devilin Pixy

1 Like

Probably related ro something I did recently, will fix this.

5 Likes

This will be fixed by:

Thx for detailed report, and sorry for the trouble.

6 Likes